blob: 1fb11b0435271eb302cffbfdf71688d85554f175 [file] [log] [blame]
Andrew Geisslerd25ed322020-06-27 00:28:28 -05001# This recipe is for bootstrapping our go-cross from a prebuilt binary of Go from golang.org.
2
3SUMMARY = "Go programming language compiler (upstream binary for bootstrap)"
4HOMEPAGE = " http://golang.org/"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=5d4950ecb7b26d2c5e4e7b4e0dd74707"
7
8PROVIDES = "go-native"
9
10SRC_URI = "https://dl.google.com/go/go${PV}.${BUILD_GOOS}-${BUILD_GOARCH}.tar.gz;name=go_${BUILD_GOTUPLE}"
Andrew Geissler706d5aa2021-02-12 15:55:30 -060011SRC_URI[go_linux_amd64.sha256sum] = "9a58494e8da722c3aef248c9227b0e9c528c7318309827780f16220998180a0d"
12SRC_URI[go_linux_arm64.sha256sum] = "a72a0b036beb4193a0214bca3fca4c5d68a38a4ccf098c909f7ce8bf08567c48"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050013
Andrew Geissler475cb722020-07-10 16:00:51 -050014UPSTREAM_CHECK_URI = "https://golang.org/dl/"
15UPSTREAM_CHECK_REGEX = "go(?P<pver>\d+(\.\d+)+)\.linux"
16
Andrew Geisslerd25ed322020-06-27 00:28:28 -050017S = "${WORKDIR}/go"
18
19inherit goarch native
20
21do_compile() {
22 :
23}
24
25make_wrapper() {
26 rm -f ${D}${bindir}/$1
27 cat <<END >${D}${bindir}/$1
28#!/bin/bash
29here=\`dirname \$0\`
30export GOROOT="${GOROOT:-\`readlink -f \$here/../lib/go\`}"
31\$here/../lib/go/bin/$1 "\$@"
32END
33 chmod +x ${D}${bindir}/$1
34}
35
36do_install() {
37 find ${S} -depth -type d -name testdata -exec rm -rf {} +
38
39 install -d ${D}${bindir} ${D}${libdir}/go
40 cp --preserve=mode,timestamps -R ${S}/ ${D}${libdir}/
41
42 for f in ${S}/bin/*
43 do
44 make_wrapper `basename $f`
45 done
46}