blob: ecb0566f378244dba70e86861fa1502401a2c32f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Ninja is a small build system with a focus on speed."
Andrew Geissler6ce62a22020-11-30 19:58:47 -06002HOMEPAGE = "https://ninja-build.org/"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native ninja-native"
7
Andrew Geissler706d5aa2021-02-12 15:55:30 -06008SRCREV = "a1f879b29c9aafe6a2bc0ba885701f8f4f19f772"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
12
13S = "${WORKDIR}/git"
14
15do_configure[noexec] = "1"
16
17do_compile_class-native() {
18 python3 ./configure.py --bootstrap
19}
20
21do_compile() {
22 python3 ./configure.py
23 ninja
24}
25
26do_install() {
27 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
28}
29
30BBCLASSEXTEND = "native nativesdk"