blob: 19a8950f15980112456b5bbf1a47ed0cd1cb0f64 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3LICENSE = "PSFv2"
4SECTION = "devel/python"
5
Andrew Geissler6ce62a22020-11-30 19:58:47 -06006LIC_FILES_CHKSUM = "file://LICENSE;md5=33223c9ef60c31e3f0e866cb09b65e83"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
9 file://run-ptest \
10 file://create_manifest3.py \
11 file://get_module_deps3.py \
12 file://python3-manifest.json \
13 file://check_build_completeness.py \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014 file://reformat_sysconfig.py \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://cgi_py.patch \
16 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
17 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
18 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
19 file://python-config.patch \
20 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 file://0001-Makefile-fix-Issue36464-parallel-build-race-problem.patch \
23 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
24 file://crosspythonpath.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
26 file://0001-test_locale.py-correct-the-test-output-format.patch \
27 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
28 file://0001-setup.py-pass-missing-libraries-to-Extension-for-mul.patch \
29 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050030 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060031 file://0001-Lib-sysconfig.py-use-libdir-values-from-configuratio.patch \
Andrew Geissler706d5aa2021-02-12 15:55:30 -060032 file://CVE-2020-27619.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 "
34
35SRC_URI_append_class-native = " \
36 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
37 file://12-distutils-prefix-is-inside-staging-area.patch \
38 file://0001-Don-t-search-system-for-headers-libraries.patch \
39 "
Andrew Geissler706d5aa2021-02-12 15:55:30 -060040
41SRC_URI[sha256sum] = "9c73e63c99855709b9be0b3cc9e5b072cb60f37311e8c4e50f15576a0bf82854"
Andrew Geissler82c905d2020-04-13 13:39:40 -050042
43# exclude pre-releases for both python 2.x and 3.x
44UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
Andrew Geissler4c19ea12020-10-27 13:52:24 -050045UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
Andrew Geissler82c905d2020-04-13 13:39:40 -050046
47CVE_PRODUCT = "python"
48
Andrew Geissler6ce62a22020-11-30 19:58:47 -060049# Upstream consider this expected behaviour
50CVE_CHECK_WHITELIST += "CVE-2007-4559"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051# This is not exploitable when glibc has CVE-2016-10739 fixed.
52CVE_CHECK_WHITELIST += "CVE-2019-18348"
53
Andrew Geissler6ce62a22020-11-30 19:58:47 -060054# This is windows only issue.
55CVE_CHECK_WHITELIST += "CVE-2020-15523"
56
57PYTHON_MAJMIN = "3.9"
Andrew Geissler82c905d2020-04-13 13:39:40 -050058
59S = "${WORKDIR}/Python-${PV}"
60
61BBCLASSEXTEND = "native nativesdk"
62
63inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
64
65MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
66
67ALTERNATIVE_${PN}-dev = "python3-config"
68ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
69ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
70
71
72DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux libtirpc libnsl2"
73DEPENDS_append_class-target = " python3-native"
74DEPENDS_append_class-nativesdk = " python3-native"
75
Andrew Geissler6ce62a22020-11-30 19:58:47 -060076EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050077EXTRA_OECONF_append_class-native = " --bindir=${bindir}/${PN}"
78
79export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
80
81EXTRANATIVEPATH += "python3-native"
82
Andrew Geissler6ce62a22020-11-30 19:58:47 -060083# LTO will be enabled via packageconfig depending upong distro features
84LTO_class-target = ""
85
Andrew Geissler82c905d2020-04-13 13:39:40 -050086CACHED_CONFIGUREVARS = " \
87 ac_cv_file__dev_ptmx=yes \
88 ac_cv_file__dev_ptc=no \
89 ac_cv_working_tzset=yes \
90"
Andrew Geisslerd25ed322020-06-27 00:28:28 -050091
92def possibly_include_pgo(d):
Andrew Geissler82c905d2020-04-13 13:39:40 -050093 # PGO currently causes builds to not be reproducible, so disable it for
94 # now. See YOCTO #13407
95 if bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d) and d.getVar('BUILD_REPRODUCIBLE_BINARIES') != '1':
Andrew Geisslerd25ed322020-06-27 00:28:28 -050096 return 'pgo'
97
98 return ''
Andrew Geissler82c905d2020-04-13 13:39:40 -050099
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600100PACKAGECONFIG_class-target ??= "readline ${@possibly_include_pgo(d)} gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500101PACKAGECONFIG_class-native ??= "readline gdbm"
102PACKAGECONFIG_class-nativesdk ??= "readline gdbm"
103PACKAGECONFIG[readline] = ",,readline"
104# Use profile guided optimisation by running PyBench inside qemu-user
105PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
106PACKAGECONFIG[tk] = ",,tk"
107PACKAGECONFIG[gdbm] = ",,gdbm"
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600108PACKAGECONFIG[lto] = "--with-lto,,"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500109
110do_configure_prepend () {
111 mkdir -p ${B}/Modules
112 cat > ${B}/Modules/Setup.local << EOF
113*disabled*
114${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
115${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
116EOF
117}
118
119CPPFLAGS_append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
120
121EXTRA_OEMAKE = '\
122 STAGING_LIBDIR=${STAGING_LIBDIR} \
123 STAGING_INCDIR=${STAGING_INCDIR} \
124 LIB=${baselib} \
125'
126
127do_compile_prepend_class-target() {
128 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
129 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
130 cat >pgo-wrapper <<EOF
131#!/bin/sh
132cd ${B}
133$qemu_binary "\$@"
134EOF
135 chmod +x pgo-wrapper
136 fi
137}
138
139do_install_prepend() {
140 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
141}
142
143do_install_append_class-target() {
144 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
145}
146
147do_install_append_class-native() {
148 # Make sure we use /usr/bin/env python
149 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
150 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
151 done
152 # Add a symlink to the native Python so that scripts can just invoke
153 # "nativepython" and get the right one without needing absolute paths
154 # (these often end up too long for the #! parser in the kernel as the
155 # buffer is 128 bytes long).
156 ln -s python3-native/python3 ${D}${bindir}/nativepython3
157}
158
159do_install_append() {
160 mkdir -p ${D}${libdir}/python-sysconfigdata
161 sysconfigfile=`find ${D} -name _sysconfig*.py`
162 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
163
164 sed -i \
165 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
166 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
167 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
168 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
169 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
170 ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
Andrew Geissler6ce62a22020-11-30 19:58:47 -0600171
172 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
173 # being written without strict ordering, even with PYTHONHASHSEED = 0
174 # Upstream is discussing ways to solve the issue properly, until then let's
175 # just not install the problematic files.
176 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
177 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
178 rm ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
Andrew Geissler82c905d2020-04-13 13:39:40 -0500179}
180
181do_install_append_class-nativesdk () {
182 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
183}
184
185SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
186PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
187
188py_package_preprocess () {
189 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
190 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
191 -e 's|${DEBUG_PREFIX_MAP}||g' \
192 -e 's:${HOSTTOOLS_DIR}/::g' \
193 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
194 -e 's:${RECIPE_SYSROOT}::g' \
195 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
196 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
197 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
198 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
199
200 # Reformat _sysconfigdata after modifying it so that it remains
201 # reproducible
202 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
203 python3 ${WORKDIR}/reformat_sysconfig.py $c
204 done
205
206 # Recompile _sysconfigdata after modifying it
207 cd ${PKGD}
208 sysconfigfile=`find . -name _sysconfigdata_*.py`
209 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
210 -c "from py_compile import compile; compile('$sysconfigfile')"
211 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
212 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
213 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
214 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
215 cd -
216
217 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
218
219 #Remove the unneeded copy of target sysconfig data
220 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
221}
222
223# We want bytecode precompiled .py files (.pyc's) by default
224# but the user may set it on their own conf
225INCLUDE_PYCS ?= "1"
226
227python(){
228 import collections, json
229
230 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
231 # This python changes the datastore based on the contents of a file, so mark
232 # that dependency.
233 bb.parse.mark_dependency(d, filename)
234
235 with open(filename) as manifest_file:
236 manifest_str = manifest_file.read()
237 json_start = manifest_str.find('# EOC') + 6
238 manifest_file.seek(json_start)
239 manifest_str = manifest_file.read()
240 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
241
242 # First set RPROVIDES for -native case
243 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
244 pn = 'python3'
245 rprovides = d.getVar('RPROVIDES').split()
246
247 # ${PN}-misc-native is not in the manifest
248 rprovides.append(pn + '-misc-native')
249
250 for key in python_manifest:
251 pypackage = pn + '-' + key + '-native'
252 if pypackage not in rprovides:
253 rprovides.append(pypackage)
254
255 d.setVar('RPROVIDES_class-native', ' '.join(rprovides))
256
257 # Then work on the target
258 include_pycs = d.getVar('INCLUDE_PYCS')
259
260 packages = d.getVar('PACKAGES').split()
261 pn = d.getVar('PN')
262
263 newpackages=[]
264 for key in python_manifest:
265 pypackage = pn + '-' + key
266
267 if pypackage not in packages:
268 # We need to prepend, otherwise python-misc gets everything
269 # so we use a new variable
270 newpackages.append(pypackage)
271
272 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
273 d.setVar('FILES_' + pypackage, '')
274 for value in python_manifest[key]['files']:
275 d.appendVar('FILES_' + pypackage, ' ' + value)
276
277 # Add cached files
278 if include_pycs == '1':
279 for value in python_manifest[key]['cached']:
280 d.appendVar('FILES_' + pypackage, ' ' + value)
281
282 for value in python_manifest[key]['rdepends']:
283 # Make it work with or without $PN
284 if '${PN}' in value:
285 value=value.split('-', 1)[1]
286 d.appendVar('RDEPENDS_' + pypackage, ' ' + pn + '-' + value)
287
288 for value in python_manifest[key].get('rrecommends', ()):
289 if '${PN}' in value:
290 value=value.split('-', 1)[1]
291 d.appendVar('RRECOMMENDS_' + pypackage, ' ' + pn + '-' + value)
292
293 d.setVar('SUMMARY_' + pypackage, python_manifest[key]['summary'])
294
295 # Prepending so to avoid python-misc getting everything
296 packages = newpackages + packages
297 d.setVar('PACKAGES', ' '.join(packages))
298 d.setVar('ALLOW_EMPTY_${PN}-modules', '1')
299 d.setVar('ALLOW_EMPTY_${PN}-pkgutil', '1')
300}
301
302# Files needed to create a new manifest
303
304do_create_manifest() {
305 # This task should be run with every new release of Python.
306 # We must ensure that PACKAGECONFIG enables everything when creating
307 # a new manifest, this is to base our new manifest on a complete
308 # native python build, containing all dependencies, otherwise the task
309 # wont be able to find the required files.
310 # e.g. BerkeleyDB is an optional build dependency so it may or may not
311 # be present, we must ensure it is.
312
313 cd ${WORKDIR}
314 # This needs to be executed by python-native and NOT by HOST's python
315 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
316 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
317}
318
319# bitbake python -c create_manifest
320addtask do_create_manifest
321
322# Make sure we have native python ready when we create a new manifest
323do_create_manifest[depends] += "${PN}:do_prepare_recipe_sysroot"
324do_create_manifest[depends] += "${PN}:do_patch"
325
326# manual dependency additions
327RRECOMMENDS_${PN}-core_append_class-nativesdk = " nativesdk-python3-modules"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500328RRECOMMENDS_${PN}-crypt_append_class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
329RRECOMMENDS_${PN}-crypt_append_class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500330
331# For historical reasons PN is empty and provided by python3-modules
332FILES_${PN} = ""
333RPROVIDES_${PN}-modules = "${PN}"
334
335FILES_${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
336FILES_${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
337
338# provide python-pyvenv from python3-venv
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500339RPROVIDES_${PN}-venv += "${MLPREFIX}python3-pyvenv"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500340
341# package libpython3
342PACKAGES =+ "libpython3 libpython3-staticdev"
343FILES_libpython3 = "${libdir}/libpython*.so.*"
344FILES_libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
345INSANE_SKIP_${PN}-dev += "dev-elf"
346
347# catch all the rest (unsorted)
348PACKAGES += "${PN}-misc"
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500349RDEPENDS_${PN}-misc += "\
350 ${PN}-core \
351 ${PN}-email \
352 ${PN}-codecs \
353 ${PN}-pydoc \
354 ${PN}-pickle \
355 ${PN}-audio \
356 ${PN}-numbers \
357"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500358RDEPENDS_${PN}-modules_append_class-target = " ${MLPREFIX}python3-misc"
359RDEPENDS_${PN}-modules_append_class-nativesdk = " ${MLPREFIX}python3-misc"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500360FILES_${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
361
362# catch manpage
363PACKAGES += "${PN}-man"
364FILES_${PN}-man = "${datadir}/man"
365
366# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
367RDEPENDS_libpython3_append_libc-glibc = " libgcc"
Andrew Geissler475cb722020-07-10 16:00:51 -0500368RDEPENDS_${PN}-ctypes_append_libc-glibc = " ${MLPREFIX}ldconfig"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500369RDEPENDS_${PN}-ptest = "${PN}-modules ${PN}-tests unzip bzip2 libgcc tzdata-europe coreutils sed"
370RDEPENDS_${PN}-ptest_append_libc-glibc = " locale-base-tr-tr.iso-8859-9"
371RDEPENDS_${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', 'tk tk-lib', '', d)}"
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500372RDEPENDS_${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter tcl', '', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500373RDEPENDS_${PN}-dev = ""
374
Andrew Geissler1e34c2d2020-05-29 16:02:59 -0500375RDEPENDS_${PN}-tests_append_class-target = " ${MLPREFIX}bash"
376RDEPENDS_${PN}-tests_append_class-nativesdk = " ${MLPREFIX}bash"