blob: edf9b29c8fe94d94f1ac7a036407b657ab495943 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU grep utility"
2HOMEPAGE = "http://savannah.gnu.org/projects/grep/"
3BUGTRACKER = "http://savannah.gnu.org/bugs/?group=grep"
4SECTION = "console/utils"
5LICENSE = "GPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
7
8SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz"
9
Andrew Geissler09209ee2020-12-13 08:44:15 -060010SRC_URI[sha256sum] = "667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12inherit autotools gettext texinfo pkgconfig
13
14# Fix "Argument list too long" error when len(TMPDIR) = 410
15acpaths = "-I ./m4"
16
17do_configure_prepend () {
18 sed -i -e '1s,#!@SHELL@,#!/bin/sh,' ${S}/src/egrep.sh
19 rm -f ${S}/m4/init.m4
20}
21
22do_install () {
23 autotools_do_install
24 if [ "${base_bindir}" != "${bindir}" ]; then
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/grep ${D}${base_bindir}/grep
27 mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep
28 mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep
29 rmdir ${D}${bindir}/
30 fi
31}
32
33inherit update-alternatives
34
35PACKAGECONFIG ??= "pcre"
36PACKAGECONFIG[pcre] = "--enable-perl-regexp,--disable-perl-regexp,libpcre"
37
38ALTERNATIVE_PRIORITY = "100"
39
40ALTERNATIVE_${PN} = "grep egrep fgrep"
41ALTERNATIVE_LINK_NAME[grep] = "${base_bindir}/grep"
42ALTERNATIVE_LINK_NAME[egrep] = "${base_bindir}/egrep"
43ALTERNATIVE_LINK_NAME[fgrep] = "${base_bindir}/fgrep"