blob: e39847834969b52cd009690eca986278487a80dd [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "GNU Troff software"
2DESCRIPTION = "The groff (GNU troff) software is a typesetting package which reads plain text mixed with \
3formatting commands and produces formatted output."
4SECTION = "base"
5HOMEPAGE = "http://www.gnu.org/software/groff/"
6LICENSE = "GPLv3"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
9
10SRC_URI = "${GNU_MIRROR}/groff/groff-${PV}.tar.gz \
11 file://0001-replace-perl-w-with-use-warnings.patch \
12 file://groff-not-search-fonts-on-build-host.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040013 file://0001-support-musl.patch \
Brad Bishop08902b02019-08-20 09:16:51 -040014 file://0001-Include-config.h.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-Make-manpages-mulitlib-identical.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040016"
17
18SRC_URI[md5sum] = "08fb04335e2f5e73f23ea4c3adbf0c5f"
19SRC_URI[sha256sum] = "e78e7b4cb7dec310849004fa88847c44701e8d133b5d4c13057d876c1bad0293"
20
21DEPENDS = "bison-native"
22RDEPENDS_${PN} += "perl sed"
23
24inherit autotools-brokensep texinfo multilib_script pkgconfig
25
26MULTILIB_SCRIPTS = "${PN}:${bindir}/gpinyin ${PN}:${bindir}/groffer ${PN}:${bindir}/grog"
27
28EXTRA_OECONF = "--without-x --without-doc"
29PARALLEL_MAKE = ""
30
Andrew Geissler706d5aa2021-02-12 15:55:30 -060031CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl' ac_cv_path_BASH_PROG='no'"
Brad Bishopc342db32019-05-15 21:57:59 -040032
33do_install_append() {
34 # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
35 # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
36 for i in afmtodit mmroff gropdf pdfmom grog; do
37 if [ -f ${D}${bindir}/$i ]; then
38 sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,' ${D}${bindir}/$i
39 fi
40 done
41 if [ -e ${D}${libdir}/charset.alias ]; then
42 rm -rf ${D}${libdir}/charset.alias
43 fi
44
45 # awk is located at /usr/bin/, not /bin/
46 SPECIAL_AWK=`find ${D} -name special.awk`
47 if [ -f ${SPECIAL_AWK} ]; then
48 sed -i -e 's:#!.*awk:#! ${USRBINPATH}/awk:' ${SPECIAL_AWK}
49 fi
50
51 # not ship /usr/bin/glilypond and its releated files in embedded target system
52 rm -rf ${D}${bindir}/glilypond
53 rm -rf ${D}${libdir}/groff/glilypond
54 rm -rf ${D}${mandir}/man1/glilypond*
55}
56
57do_install_append_class-native() {
58 create_cmdline_wrapper ${D}/${bindir}/groff \
59 -F${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/font \
60 -M${STAGING_DIR_NATIVE}${datadir_native}/groff/${PV}/tmac
61}
62
63FILES_${PN} += "${libdir}/${BPN}/site-tmac \
64 ${libdir}/${BPN}/groffer/"
65
66BBCLASSEXTEND = "native"