blob: 7acf15b360996e9b584b3038222940d2e41ed4eb [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060030SRCREV = "da2f34028f046a208aa2fed5e287df2538e69f91"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031
32SRC_URI = "git://github.com/linux-test-project/ltp.git \
33 file://0001-build-Add-option-to-select-libc-implementation.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050034 file://0007-Fix-test_proc_kill-hanging.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 file://0001-Add-more-musl-exclusions.patch \
Andrew Geissler635e0e42020-08-21 15:58:33 -050036 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050037 "
38
39S = "${WORKDIR}/git"
40
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050041inherit autotools-brokensep pkgconfig
Andrew Geissler82c905d2020-04-13 13:39:40 -050042
43TARGET_CC_ARCH += "${LDFLAGS}"
44
45export prefix = "/opt/${PN}"
46export exec_prefix = "/opt/${PN}"
47
48PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
49EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
Andrew Geissler635e0e42020-08-21 15:58:33 -050050EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
Andrew Geissler82c905d2020-04-13 13:39:40 -050051# ltp network/rpc test cases ftbfs when libtirpc is found
52EXTRA_OECONF += " --without-tirpc "
53
54do_install(){
55 install -d ${D}${prefix}/
56 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
57
58 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
59 # as it lacks dependency on some perl moudle such as LWP::Simple
60 # And this script previously works as a tool for analyzing failures from LTP
61 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
62 # http://khack.osdl.org to retrieve ltp test results run on
63 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
64 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
65
66 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
67 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
68
69 # Makefile were configured in the build system
70 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
71 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
72 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
73 -e 's@[^ ]*--sysroot=[^ "]*@@g'
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050074
75 # The controllers memcg_stree test seems to cause us hangs and takes 900s
76 # (maybe we expect more regular output?), anyhow, skip it
77 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler82c905d2020-04-13 13:39:40 -050078}
79
80RDEPENDS_${PN} = "\
81 attr \
82 bash \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050083 bc \
84 coreutils \
Andrew Geissler82c905d2020-04-13 13:39:40 -050085 cpio \
86 cronie \
87 curl \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050088 e2fsprogs \
Andrew Geissler82c905d2020-04-13 13:39:40 -050089 e2fsprogs-mke2fs \
90 expect \
91 file \
92 gawk \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050093 gdb \
Andrew Geissler82c905d2020-04-13 13:39:40 -050094 gzip \
95 iproute2 \
96 ldd \
97 libaio \
98 logrotate \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050099 net-tools \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500100 perl \
101 python3-core \
102 procps \
103 quota \
104 unzip \
105 util-linux \
106 which \
107 tar \
108"
109
110FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
111
112# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
113INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
114INSANE_SKIP_${PN} += "already-stripped staticdev"
115
116# Avoid file dependency scans, as LTP checks for things that may or may not
117# exist on the running system. For instance it has specific checks for
118# csh and ksh which are not typically part of OpenEmbedded systems (but
119# can be added via additional layers.)
120SKIP_FILEDEPS_${PN} = '1'