blob: 513d66f9fcafbc8db406e4b47198221e8a6f1a05 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "OpenMAX IL plugins for GStreamer"
2HOMEPAGE = "http://gstreamer.freedesktop.org/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LICENSE_FLAGS = "commercial"
7LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
8 file://omx/gstomx.h;beginline=1;endline=21;md5=5c8e1fca32704488e76d2ba9ddfa935f"
9
10SRC_URI = "https://gstreamer.freedesktop.org/src/gst-omx/gst-omx-${PV}.tar.xz"
11
Andrew Geissler706d5aa2021-02-12 15:55:30 -060012SRC_URI[sha256sum] = "42a8e0f9518b94655981ede441638f9f9395f4b1b9a4b329f068ee793975a965"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14S = "${WORKDIR}/gst-omx-${PV}"
15
16DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/libomxil"
17
18inherit meson pkgconfig upstream-version-is-even
19
20GSTREAMER_1_0_OMX_TARGET ?= "bellagio"
21GSTREAMER_1_0_OMX_CORE_NAME ?= "${libdir}/libomxil-bellagio.so.0"
22
23EXTRA_OEMESON += "-Dtarget=${GSTREAMER_1_0_OMX_TARGET}"
24
25python __anonymous () {
26 omx_target = d.getVar("GSTREAMER_1_0_OMX_TARGET")
27 if omx_target in ['generic', 'bellagio']:
28 # Bellagio headers are incomplete (they are missing the OMX_VERSION_MAJOR,#
29 # OMX_VERSION_MINOR, OMX_VERSION_REVISION, and OMX_VERSION_STEP macros);
30 # appending a directory path to gst-omx' internal OpenMAX IL headers fixes this
31 d.appendVar("CFLAGS", " -I${S}/omx/openmax")
32 elif omx_target == "rpi":
33 # Dedicated Raspberry Pi OpenMAX IL support makes this package machine specific
34 d.setVar("PACKAGE_ARCH", d.getVar("MACHINE_ARCH"))
35}
36
37set_omx_core_name() {
38 sed -i -e "s;^core-name=.*;core-name=${GSTREAMER_1_0_OMX_CORE_NAME};" "${D}${sysconfdir}/xdg/gstomx.conf"
39}
40do_install[postfuncs] += " set_omx_core_name "
41
42FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
43FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
44
45VIRTUAL-RUNTIME_libomxil ?= "libomxil"
46RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_libomxil}"