blob: c0c5d271d008fd2216ee8ee63ecb1d58011f1973 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
8SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
Andrew Geissler706d5aa2021-02-12 15:55:30 -06009SRC_URI[sha256sum] = "42b289422f7ab32757670848cf2245c5a8a8b08a665a9cab65ded8d69364f6f6"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060010
11DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
12RDEPENDS_${PN} += "gstreamer1.0 gstreamer1.0-plugins-base python3-pygobject"
13
14PNREAL = "gst-python"
15
16S = "${WORKDIR}/${PNREAL}-${PV}"
17
18# gobject-introspection is mandatory and cannot be configured
19REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
20UNKNOWN_CONFIGURE_WHITELIST_append = " introspection"
21
22inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check