blob: acf5598a62624404e2fbf3b3b337092b380abf6f [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "VA-API support to GStreamer"
2DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
3based plugins for GStreamer and helper libraries: `vaapidecode', \
4`vaapiconvert', and `vaapisink'."
5
6REALPN = "gstreamer-vaapi"
7
8LICENSE = "LGPLv2.1+"
9LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
Andrew Geissler6ce62a22020-11-30 19:58:47 -060011SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
Andrew Geissler706d5aa2021-02-12 15:55:30 -060013SRC_URI[sha256sum] = "400d3c42810b50b4566df03f37319a6bdd758f969560c40147e7d9a3b0e8a6ea"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/${REALPN}-${PV}"
16DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
17
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018inherit meson pkgconfig features_check upstream-version-is-even
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20REQUIRED_DISTRO_FEATURES ?= "opengl"
21
22EXTRA_OEMESON += " \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060023 -Ddoc=disabled \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 -Dexamples=disabled \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060025 -Dtests=enabled \
Andrew Geissler82c905d2020-04-13 13:39:40 -050026"
27
Andrew Geissler82c905d2020-04-13 13:39:40 -050028PACKAGES =+ "${PN}-tests"
29
30# OpenGL packageconfig factored out to make it easy for distros
31# and BSP layers to pick either glx, egl, or no GL. By default,
32# try detecting X11 first, and if found (with OpenGL), use GLX,
33# otherwise try to check if EGL can be used.
34PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
35 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
36 '', d), d)}"
37
38PACKAGECONFIG ??= "drm encoders \
39 ${PACKAGECONFIG_GL} \
40 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
41
42PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm"
43PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl"
44PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no"
45PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl"
46PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols"
47PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender"
48
49FILES_${PN} += "${libdir}/gstreamer-*/*.so"
50FILES_${PN}-dbg += "${libdir}/gstreamer-*/.debug"
51FILES_${PN}-dev += "${libdir}/gstreamer-*/*.a"
52FILES_${PN}-tests = "${bindir}/*"