blob: 31370f32398d07c70b9837e7de87ae95a30239cd [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050018 file://0001-Fix-build-with-musl.patch \
19 file://include_array.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060020 file://include_xutil.patch \
Andrew Geissler706d5aa2021-02-12 15:55:30 -060021 file://0001-ICU-68.1-no-longer-exposes-FALSE-and-TRUE-macros-by-.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050022 "
Andrew Geissler706d5aa2021-02-12 15:55:30 -060023SRC_URI[sha256sum] = "c467e0bc2bc610c2570928e3fd63cedaadc4719cbf9b04aa99f79dd71ad5682a"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
26
27ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
28REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
29
30CVE_PRODUCT = "webkitgtk webkitgtk\+"
31
32DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
33 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
34 pango icu bison-native gawk intltool-native libwebp \
35 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
36 ruby-native libnotify gstreamer1.0-plugins-bad \
37 gettext-native glib-2.0 glib-2.0-native libtasn1 \
38 "
39
Andrew Geissler6ce62a22020-11-30 19:58:47 -060040PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050041 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
42 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050043 enchant \
44 libsecret \
45 "
46
47PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
48PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
49PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
50PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
51PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
52PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060053PACKAGECONFIG[opengl] = "-DENABLE_GRAPHICS_CONTEXT_GL=ON,-DENABLE_GRAPHICS_CONTEXT_GL=OFF,virtual/libgl"
Andrew Geissler82c905d2020-04-13 13:39:40 -050054PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
55PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
56PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
57PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060058PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
Andrew Geissler82c905d2020-04-13 13:39:40 -050059
60# webkitgtk is full of /usr/bin/env python, particular for generating docs
61do_configure[postfuncs] += "setup_python_link"
62setup_python_link() {
63 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
64 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
65 fi
66}
67
68EXTRA_OECMAKE = " \
69 -DPORT=GTK \
70 -DCMAKE_BUILD_TYPE=Release \
71 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
72 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
73 -DENABLE_MINIBROWSER=ON \
74 -DPYTHON_EXECUTABLE=`which python3` \
75 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
76 "
77
78# Javascript JIT is not supported on ARC
79EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
80# By default 25-bit "medium" calls are used on ARC
81# which is not enough for binaries larger than 32 MiB
82CFLAGS_append_arc = " -mlong-calls"
83CXXFLAGS_append_arc = " -mlong-calls"
84
85# Javascript JIT is not supported on powerpc
86EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
87EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
88
89# ARM JIT code does not build on ARMv4/5/6 anymore
90EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
91EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
92EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
93
94EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
95EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
96
Andrew Geissler6ce62a22020-11-30 19:58:47 -060097# JIT and gold linker does not work on RISCV
98EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
99EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
100
Andrew Geissler82c905d2020-04-13 13:39:40 -0500101# JIT not supported on MIPS either
102EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
103
104# JIT not supported on X32
105# An attempt was made to upstream JIT support for x32 in
106# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
107# unresolved due to limited X32 adoption.
108EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
109
110SECURITY_CFLAGS_remove_aarch64 = "-fpie"
111SECURITY_CFLAGS_append_aarch64 = " -fPIE"
112
113FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
114
115RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
116
117# http://errors.yoctoproject.org/Errors/Details/20370/
118ARM_INSTRUCTION_SET_armv4 = "arm"
119ARM_INSTRUCTION_SET_armv5 = "arm"
120ARM_INSTRUCTION_SET_armv6 = "arm"
121
122# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
123# https://bugs.webkit.org/show_bug.cgi?id=159880
124# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
125# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
126ARM_INSTRUCTION_SET_armv7a = "thumb"
127ARM_INSTRUCTION_SET_armv7r = "thumb"
128ARM_INSTRUCTION_SET_armv7ve = "thumb"
129
130# introspection inside qemu-arm hangs forever on musl/arm builds
131# therefore disable GI_DATA
132GI_DATA_ENABLED_libc-musl_armv7a = "False"
133GI_DATA_ENABLED_libc-musl_armv7ve = "False"
134
135# Can't be built with ccache
136CCACHE_DISABLE = "1"
Andrew Geissler09209ee2020-12-13 08:44:15 -0600137
138PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
139src_package_preprocess () {
140 # Trim build paths from comments in generated sources to ensure reproducibility
141 sed -i -e "s,${WORKDIR},,g" \
142 ${B}/DerivedSources/webkit2gtk/webkit2/*.cpp \
143 ${B}/DerivedSources/ForwardingHeaders/JavaScriptCore/*.h \
144 ${B}/DerivedSources/JavaScriptCore/*.h \
145 ${B}/DerivedSources/JavaScriptCore/yarr/*.h \
146 ${B}/DerivedSources/MiniBrowser/*.c
147}
148