blob: 7073af8c986adf3364871958bb0ad7d103639a76 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Apache Portable Runtime (APR) library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "util-linux"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4dfd4cd216828c8cae5de5a12f3844c8 \
8 file://include/apr_lib.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
9
10BBCLASSEXTEND = "native nativesdk"
11
12SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.bz2 \
13 file://run-ptest \
Brad Bishopc342db32019-05-15 21:57:59 -040014 file://0002-apr-Remove-workdir-path-references-from-installed-ap.patch \
15 file://0003-Makefile.in-configure.in-support-cross-compiling.patch \
16 file://0004-Fix-packet-discards-HTTP-redirect.patch \
17 file://0005-configure.in-fix-LTFLAGS-to-make-it-work-with-ccache.patch \
18 file://0006-apr-fix-off_t-size-doesn-t-match-in-glibc-when-cross.patch \
19 file://0007-explicitly-link-libapr-against-phtread-to-make-gold-.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -040020 file://libtoolize_check.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050021 file://0001-Add-option-to-disable-timed-dependant-tests.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040022 "
23
24SRC_URI[md5sum] = "7a14a83d664e87599ea25ff4432e48a7"
25SRC_URI[sha256sum] = "e2e148f0b2e99b8e5c6caa09f6d4fb4dd3e83f744aa72a952f94f5a14436f7ea"
26
Andrew Geissler82c905d2020-04-13 13:39:40 -050027inherit autotools-brokensep lib_package binconfig multilib_header ptest multilib_script
Brad Bishopc342db32019-05-15 21:57:59 -040028
29OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
30
31# Added to fix some issues with cmake. Refer to https://github.com/bmwcarit/meta-ros/issues/68#issuecomment-19896928
32CACHED_CONFIGUREVARS += "apr_cv_mutex_recursive=yes"
33
34# Also suppress trying to use sctp.
35#
36CACHED_CONFIGUREVARS += "ac_cv_header_netinet_sctp_h=no ac_cv_header_netinet_sctp_uio_h=no"
37
38CACHED_CONFIGUREVARS += "ac_cv_sizeof_struct_iovec=yes"
39CACHED_CONFIGUREVARS += "ac_cv_file__dev_zero=yes"
40
41PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
42PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043PACKAGECONFIG[timed-tests] = "--enable-timed-tests,--disable-timed-tests,"
Brad Bishopc342db32019-05-15 21:57:59 -040044
45do_configure_prepend() {
46 # Avoid absolute paths for grep since it causes failures
47 # when using sstate between different hosts with different
48 # install paths for grep.
49 export GREP="grep"
50
51 cd ${S}
Brad Bishop00e122a2019-10-05 11:10:57 -040052 # The "2" means libtool version 2.
53 ./buildconf 2
Brad Bishopc342db32019-05-15 21:57:59 -040054}
55
Andrew Geissler82c905d2020-04-13 13:39:40 -050056MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apr-1-config \
57 ${PN}-dev:${datadir}/build-1/apr_rules.mk"
58
Brad Bishopc342db32019-05-15 21:57:59 -040059FILES_${PN}-dev += "${libdir}/apr.exp ${datadir}/build-1/*"
60RDEPENDS_${PN}-dev += "bash"
61
Brad Bishop393846f2019-05-20 12:24:11 -040062RDEPENDS_${PN}-ptest += "libgcc"
63
Brad Bishopc342db32019-05-15 21:57:59 -040064#for some reason, build/libtool.m4 handled by buildconf still be overwritten
65#when autoconf, so handle it again.
66do_configure_append() {
67 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/libtool.m4
68 sed -i -e 's/LIBTOOL=\(.*\)top_build/LIBTOOL=\1apr_build/' ${S}/build/apr_rules.mk
69}
70
71do_install_append() {
72 oe_multilib_header apr.h
73 install -d ${D}${datadir}/apr
74}
75
76do_install_append_class-target() {
77 sed -i -e 's,${DEBUG_PREFIX_MAP},,g' \
78 -e 's,${STAGING_DIR_HOST},,g' ${D}${datadir}/build-1/apr_rules.mk
79 sed -i -e 's,${STAGING_DIR_HOST},,g' \
80 -e 's,APR_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
81 -e 's,APR_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apr-1-config
82}
83
84SSTATE_SCAN_FILES += "apr_rules.mk libtool"
85
86SYSROOT_PREPROCESS_FUNCS += "apr_sysroot_preprocess"
87
88apr_sysroot_preprocess () {
89 d=${SYSROOT_DESTDIR}${datadir}/apr
90 install -d $d/
91 cp ${S}/build/apr_rules.mk $d/
92 sed -i s,apr_builddir=.*,apr_builddir=,g $d/apr_rules.mk
93 sed -i s,apr_builders=.*,apr_builders=,g $d/apr_rules.mk
94 sed -i s,LIBTOOL=.*,LIBTOOL=${HOST_SYS}-libtool,g $d/apr_rules.mk
95 sed -i s,\$\(apr_builders\),${STAGING_DATADIR}/apr/,g $d/apr_rules.mk
96 cp ${S}/build/mkdir.sh $d/
97 cp ${S}/build/make_exports.awk $d/
98 cp ${S}/build/make_var_export.awk $d/
99 cp ${S}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${datadir}/build-1/libtool
100}
101
102do_compile_ptest() {
103 cd ${S}/test
104 oe_runmake
105}
106
107do_install_ptest() {
108 t=${D}${PTEST_PATH}/test
109 mkdir -p $t/.libs
110 cp -r ${S}/test/data $t/
111 cp -r ${S}/test/.libs/*.so $t/.libs/
112 cp ${S}/test/proc_child $t/
113 cp ${S}/test/readchild $t/
114 cp ${S}/test/sockchild $t/
115 cp ${S}/test/sockperf $t/
116 cp ${S}/test/testall $t/
117 cp ${S}/test/tryread $t/
118}
119
120export CONFIG_SHELL="/bin/bash"