blob: fbb1fe72d78e31e2d781b5d00db1be075cbce453 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7
8SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \
9 file://run-ptest \
10 file://ptest.patch \
Andrew Geissler706d5aa2021-02-12 15:55:30 -060011 file://gdbm-fix-link-failure-against-gcc-10.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 "
13
Andrew Geissler706d5aa2021-02-12 15:55:30 -060014SRC_URI[md5sum] = "988dc82182121c7570e0cb8b4fcd5415"
15SRC_URI[sha256sum] = "86e613527e5dba544e73208f42b78b7c022d4fa5a6d5498bf18c8d6f745b91dc"
Brad Bishop19323692019-04-05 15:28:33 -040016
17inherit autotools gettext texinfo lib_package ptest
18
19# Needed for dbm python module
Andrew Geissler82c905d2020-04-13 13:39:40 -050020EXTRA_OECONF = "--enable-libgdbm-compat --without-readline"
Brad Bishop19323692019-04-05 15:28:33 -040021
22# Stop presence of dbm/nbdm on the host contaminating builds
23CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
24
25BBCLASSEXTEND = "native nativesdk"
26
Brad Bishop19323692019-04-05 15:28:33 -040027do_install_append () {
28 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
29 # these headers
30 install -d ${D}${includedir}/gdbm
31 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
32 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
33}
34
35RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin"
36
37do_compile_ptest() {
38 oe_runmake -C tests buildtests
39}
40
41PACKAGES =+ "${PN}-compat \
42 "
43FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
44 "