blob: b936db50d16ec4607a06017024aad710aa9ace32 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
4
5LICENSE = "GPLv3+ & LGPLv2.1+"
6LICENSE_${PN} = "LGPLv2.1+"
7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://arm_eabi.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060022 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
Andrew Geissler706d5aa2021-02-12 15:55:30 -060024SRC_URI[sha256sum] = "0ea8c3283de8d8335d7ae338ef27c53a916f15f382753b174c18b45ffd481558"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26inherit autotools texinfo pkgconfig gettext lib_package gtk-doc
27
28PACKAGECONFIG ??= "libidn"
29
30# You must also have CONFIG_SECCOMP enabled in the kernel for
31# seccomp to work.
32PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
33PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
34PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
35PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
36PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
37
38EXTRA_OECONF = " \
39 --enable-doc \
40 --disable-libdane \
41 --disable-guile \
42 --disable-rpath \
43 --enable-local-libopts \
44 --enable-openssl-compatibility \
45 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060046 --with-librt-prefix=${STAGING_DIR_HOST}${prefix} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050047 --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \
48"
49
50# Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell.
51export POSIX_SHELL="${base_bindir}/sh"
52
53LDFLAGS_append_libc-musl = " -largp"
54
55do_configure_prepend() {
56 for dir in . lib; do
57 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
58 done
59}
60
61PACKAGES =+ "${PN}-openssl ${PN}-xx"
62
63FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
64FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
65FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
66
67BBCLASSEXTEND = "native nativesdk"