blob: 98aa6b7be6836cba5e5a62c4770610480a09fe8a [file] [log] [blame]
Andrew Geisslerd25ed322020-06-27 00:28:28 -05001SUMMARY = "International Component for Unicode libraries"
2DESCRIPTION = "The International Component for Unicode (ICU) is a mature, \
3portable set of C/C++ and Java libraries for Unicode support, software \
4internationalization (I18N) and globalization (G11N), giving applications the \
5same results on all platforms."
6HOMEPAGE = "http://site.icu-project.org/"
7
8LICENSE = "ICU"
9DEPENDS = "icu-native"
10DEPENDS_class-native = ""
11
12CVE_PRODUCT = "international_components_for_unicode"
13
14S = "${WORKDIR}/icu/source"
15SPDX_S = "${WORKDIR}/icu"
16STAGING_ICU_DIR_NATIVE = "${STAGING_DATADIR_NATIVE}/${BPN}/${PV}"
17
18BINCONFIG = "${bindir}/icu-config"
19
20ICU_MAJOR_VER = "${@d.getVar('PV').split('.')[0]}"
21
22inherit autotools pkgconfig binconfig multilib_script
23
24MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/icu-config"
25
26# ICU needs the native build directory as an argument to its --with-cross-build option when
27# cross-compiling. Taken the situation that different builds may share a common sstate-cache
28# into consideration, the native build directory needs to be staged.
29EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
30EXTRA_OECONF_class-native = ""
31EXTRA_OECONF_class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
32
33EXTRA_OECONF_append_class-target = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' --with-data-packaging=archive', '', d)}"
34TARGET_CXXFLAGS_append = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' -DICU_DATA_DIR=\\""${datadir}/${BPN}/${PV}\\""', '', d)}"
35
36ASNEEDED = ""
37
38do_compile_prepend_class-target () {
39 # Make sure certain build host references do not end up being compiled
40 # in the image. This only affects libicutu and icu-dbg
41 sed \
42 -e 's,DU_BUILD=,DU_BUILD_unused=,g' \
43 -e '/^CPPFLAGS.*/ s,--sysroot=${STAGING_DIR_TARGET},,g' \
44 -i ${B}/tools/toolutil/Makefile
45}
46
47PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
48do_install_append_class-native() {
49 mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
50 cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
51 cp -r ${B}/config/icucross.inc ${D}/${STAGING_ICU_DIR_NATIVE}/config
52 cp -r ${B}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
53 cp -r ${B}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
54 cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
55}
56
57do_install_append_class-target() {
58 # The native pkgdata can not generate the correct data file.
59 # Use icupkg to re-generate it.
60 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
61 rm -f ${D}/${datadir}/${BPN}/${PV}/icudt${ICU_MAJOR_VER}b.dat
62 icupkg -tb ${S}/data/in/icudt${ICU_MAJOR_VER}l.dat ${D}/${datadir}/${BPN}/${PV}/icudt${ICU_MAJOR_VER}b.dat
63 fi
64
65 # Remove build host references...
66 sed -i \
67 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
68 -e 's|${DEBUG_PREFIX_MAP}||g' \
69 -e 's:${HOSTTOOLS_DIR}/::g' \
70 ${D}/${bindir}/icu-config ${D}/${libdir}/${BPN}/${PV}/Makefile.inc \
71 ${D}/${libdir}/${BPN}/${PV}/pkgdata.inc
72}
73
74PACKAGES =+ "libicudata libicuuc libicui18n libicutu libicuio"
75
76FILES_${PN}-dev += "${libdir}/${BPN}/"
77
78FILES_libicudata = "${libdir}/libicudata.so.*"
79FILES_libicuuc = "${libdir}/libicuuc.so.*"
80FILES_libicui18n = "${libdir}/libicui18n.so.*"
81FILES_libicutu = "${libdir}/libicutu.so.*"
82FILES_libicuio = "${libdir}/libicuio.so.*"
83
84BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050085
Andrew Geissler6ce62a22020-11-30 19:58:47 -060086LIC_FILES_CHKSUM = "file://../LICENSE;md5=002d2fdc32d17f0ec06e9a47f2c0c8d0"
Andrew Geissler82c905d2020-04-13 13:39:40 -050087
88def icu_download_version(d):
89 pvsplit = d.getVar('PV').split('.')
90 return pvsplit[0] + "_" + pvsplit[1]
91
92def icu_download_folder(d):
93 pvsplit = d.getVar('PV').split('.')
94 return pvsplit[0] + "-" + pvsplit[1]
95
96ICU_PV = "${@icu_download_version(d)}"
97ICU_FOLDER = "${@icu_download_folder(d)}"
98
99# http://errors.yoctoproject.org/Errors/Details/20486/
100ARM_INSTRUCTION_SET_armv4 = "arm"
101ARM_INSTRUCTION_SET_armv5 = "arm"
102
103BASE_SRC_URI = "https://github.com/unicode-org/icu/releases/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-src.tgz"
104DATA_SRC_URI = "https://github.com/unicode-org/icu/releases/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-data.zip"
105SRC_URI = "${BASE_SRC_URI};name=code \
106 ${DATA_SRC_URI};name=data \
107 file://filter.json \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500108 file://fix-install-manx.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500109 file://0001-icu-Added-armeb-support.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -0500110 "
111
112SRC_URI_append_class-target = "\
113 file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \
114 "
Andrew Geissler706d5aa2021-02-12 15:55:30 -0600115SRC_URI[code.sha256sum] = "a9f2e3d8b4434b8e53878b4308bd1e6ee51c9c7042e2b1a376abefb6fbb29f2d"
116SRC_URI[data.sha256sum] = "03ea8b4694155620548c8c0ba20444f1e7db246cc79e3b9c4fc7a960b160d510"
Andrew Geissler82c905d2020-04-13 13:39:40 -0500117
118UPSTREAM_CHECK_REGEX = "icu4c-(?P<pver>\d+(_\d+)+)-src"
119UPSTREAM_CHECK_URI = "https://github.com/unicode-org/icu/releases"
120
121EXTRA_OECONF_append_libc-musl = " ac_cv_func_strtod_l=no"
122
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500123PACKAGECONFIG ?= ""
124PACKAGECONFIG[make-icudata] = ",,,"
125
Andrew Geissler82c905d2020-04-13 13:39:40 -0500126do_make_icudata_class-target () {
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500127 ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)}
Andrew Geissler82c905d2020-04-13 13:39:40 -0500128 cd ${S}
129 rm -rf data
130 cp -a ${WORKDIR}/data .
Andrew Geissler82c905d2020-04-13 13:39:40 -0500131 AR='${BUILD_AR}' \
132 CC='${BUILD_CC}' \
133 CPP='${BUILD_CPP}' \
134 CXX='${BUILD_CXX}' \
135 RANLIB='${BUILD_RANLIB}' \
136 CFLAGS='${BUILD_CFLAGS}' \
137 CPPFLAGS='${BUILD_CPPFLAGS}' \
138 CXXFLAGS='${BUILD_CXXFLAGS}' \
139 LDFLAGS='${BUILD_LDFLAGS}' \
140 ICU_DATA_FILTER_FILE=${WORKDIR}/filter.json \
141 ./runConfigureICU Linux --with-data-packaging=archive
Andrew Geisslerd25ed322020-06-27 00:28:28 -0500142 oe_runmake
Andrew Geissler82c905d2020-04-13 13:39:40 -0500143 install -Dm644 ${S}/data/out/icudt${ICU_MAJOR_VER}l.dat ${S}/data/in/icudt${ICU_MAJOR_VER}l.dat
144}
145
146do_make_icudata() {
147 :
148}
149
150addtask make_icudata before do_configure after do_patch