blob: 710ef0172dd98ac65e804c53fa15e8522a26da16 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
7LICENSE = "GPLv2+ | BSD"
Andrew Geissler706d5aa2021-02-12 15:55:30 -06008LIC_FILES_CHKSUM = "file://COPYING;md5=a95aadbdfae7ed812bb2b7b86eb5981c \
Andrew Geissler82c905d2020-04-13 13:39:40 -05009 file://COPYING.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://COPYING.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
11 "
Andrew Geissler706d5aa2021-02-12 15:55:30 -060012SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git \
13 file://0001-Makefile-cleanup-install-for-rebuilds.patch \
14 file://0001-Make-man-pages-reproducible.patch"
15SRCREV = "933a44f33ed3d6612f7cfaa7ad1207c8da4886ba"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016S = "${WORKDIR}/git"
17
18do_configure[noexec] = "1"
19
20LDFLAGS += "-Wl,-O0"
21
22do_install () {
23 oe_runmake install INCDIR="/include" \
24 DESTDIR="${D}" \
25 PREFIX="${exec_prefix}" \
26 LIBDIR="${baselib}" \
27 INSTALL_STRIP="install"
28}
29