blob: 2fd658b4ef2f9db9a90235bc2870a91ebd49a418 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Userspace library to access USB (version 1.0)"
2HOMEPAGE = "http://libusb.sf.net"
3BUGTRACKER = "http://www.libusb.org/report"
4SECTION = "libs"
5
6LICENSE = "LGPLv2.1+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
8
9BBCLASSEXTEND = "native nativesdk"
10
11SRC_URI = "${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \
12 file://run-ptest \
13 "
14
Andrew Geissler706d5aa2021-02-12 15:55:30 -060015SRC_URI[md5sum] = "be79ed4a4a440169deec8beaac6aae33"
16SRC_URI[sha256sum] = "4fc17b2ef3502757641bf8fe2c14ad86ec86302a2b785abcb0806fd03aa1201f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050017
18S = "${WORKDIR}/libusb-${PV}"
19
20inherit autotools pkgconfig ptest
21
22PACKAGECONFIG_class-target ??= "udev"
23PACKAGECONFIG[udev] = "--enable-udev,--disable-udev,udev"
24
25EXTRA_OECONF = "--libdir=${base_libdir}"
26
27do_install_append() {
28 install -d ${D}${libdir}
29 if [ ! ${D}${libdir} -ef ${D}${base_libdir} ]; then
30 mv ${D}${base_libdir}/pkgconfig ${D}${libdir}
31 fi
32}
33
34do_compile_ptest() {
35 oe_runmake -C tests stress
36}
37
38do_install_ptest() {
39 install -m 755 ${B}/tests/.libs/stress ${D}${PTEST_PATH}
40}
41
42FILES_${PN} += "${base_libdir}/*.so.*"
43
44FILES_${PN}-dev += "${base_libdir}/*.so ${base_libdir}/*.la"