Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "The GNU inetutils are a collection of common \ |
| 2 | networking utilities and servers including ftp, ftpd, rcp, \ |
| 3 | rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \ |
| 4 | talkd, telnet, telnetd, tftp, tftpd, and uucpd." |
| 5 | HOMEPAGE = "http://www.gnu.org/software/inetutils" |
| 6 | SECTION = "net" |
| 7 | DEPENDS = "ncurses netbase readline virtual/crypt" |
| 8 | |
| 9 | LICENSE = "GPLv3" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=0c7051aef9219dc7237f206c5c4179a7" |
| 12 | |
| 13 | SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz \ |
| 14 | file://version.patch \ |
| 15 | file://inetutils-1.8-0001-printf-parse-pull-in-features.h-for-__GLIBC__.patch \ |
| 16 | file://inetutils-1.8-0003-wchar.patch \ |
| 17 | file://rexec.xinetd.inetutils \ |
| 18 | file://rlogin.xinetd.inetutils \ |
| 19 | file://rsh.xinetd.inetutils \ |
| 20 | file://telnet.xinetd.inetutils \ |
| 21 | file://tftpd.xinetd.inetutils \ |
| 22 | file://inetutils-1.9-PATH_PROCNET_DEV.patch \ |
| 23 | file://inetutils-only-check-pam_appl.h-when-pam-enabled.patch \ |
| 24 | file://0001-rcp-fix-to-work-with-large-files.patch \ |
| 25 | " |
| 26 | |
| 27 | SRC_URI[md5sum] = "04852c26c47cc8c6b825f2b74f191f52" |
| 28 | SRC_URI[sha256sum] = "be8f75eff936b8e41b112462db51adf689715658a1b09e0d6b05d11ec92cc616" |
| 29 | |
| 30 | inherit autotools gettext update-alternatives texinfo |
| 31 | |
| 32 | acpaths = "-I ./m4" |
| 33 | |
| 34 | SRC_URI += "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', '', 'file://fix-disable-ipv6.patch', d)}" |
| 35 | |
| 36 | PACKAGECONFIG ??= "ftp uucpd \ |
| 37 | ${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \ |
| 38 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6 ping6', '', d)} \ |
| 39 | " |
| 40 | PACKAGECONFIG[ftp] = "--enable-ftp,--disable-ftp,readline" |
| 41 | PACKAGECONFIG[uucpd] = "--enable-uucpd,--disable-uucpd,readline" |
| 42 | PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam" |
| 43 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6 gl_cv_socket_ipv6=no," |
| 44 | PACKAGECONFIG[ping6] = "--enable-ping6,--disable-ping6," |
| 45 | |
| 46 | EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR} \ |
| 47 | inetutils_cv_path_login=${base_bindir}/login \ |
| 48 | --with-libreadline-prefix=${STAGING_LIBDIR} \ |
| 49 | --enable-rpath=no \ |
| 50 | " |
| 51 | |
| 52 | # These are horrible for security, disable them |
| 53 | EXTRA_OECONF_append = " --disable-rsh --disable-rshd --disable-rcp \ |
| 54 | --disable-rlogin --disable-rlogind --disable-rexec --disable-rexecd" |
| 55 | |
| 56 | do_configure_prepend () { |
| 57 | export HELP2MAN='true' |
| 58 | cp ${STAGING_DATADIR_NATIVE}/gettext/config.rpath ${S}/build-aux/config.rpath |
| 59 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 60 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
| 61 | rm -f ${S}/glob/configure* |
| 62 | } |
| 63 | |
| 64 | do_install_append () { |
| 65 | install -m 0755 -d ${D}${base_sbindir} |
| 66 | install -m 0755 -d ${D}${sbindir} |
| 67 | install -m 0755 -d ${D}${sysconfdir}/xinetd.d |
| 68 | if [ "${base_bindir}" != "${bindir}" ] ; then |
| 69 | install -m 0755 -d ${D}${base_bindir} |
| 70 | mv ${D}${bindir}/ping* ${D}${base_bindir}/ |
| 71 | mv ${D}${bindir}/hostname ${D}${base_bindir}/ |
| 72 | fi |
| 73 | mv ${D}${bindir}/ifconfig ${D}${base_sbindir}/ |
| 74 | mv ${D}${libexecdir}/syslogd ${D}${base_sbindir}/ |
| 75 | mv ${D}${libexecdir}/tftpd ${D}${sbindir}/in.tftpd |
| 76 | mv ${D}${libexecdir}/telnetd ${D}${sbindir}/in.telnetd |
| 77 | if [ -e ${D}${libexecdir}/rexecd ]; then |
| 78 | mv ${D}${libexecdir}/rexecd ${D}${sbindir}/in.rexecd |
| 79 | cp ${WORKDIR}/rexec.xinetd.inetutils ${D}/${sysconfdir}/xinetd.d/rexec |
| 80 | fi |
| 81 | if [ -e ${D}${libexecdir}/rlogind ]; then |
| 82 | mv ${D}${libexecdir}/rlogind ${D}${sbindir}/in.rlogind |
| 83 | cp ${WORKDIR}/rlogin.xinetd.inetutils ${D}/${sysconfdir}/xinetd.d/rlogin |
| 84 | fi |
| 85 | if [ -e ${D}${libexecdir}/rshd ]; then |
| 86 | mv ${D}${libexecdir}/rshd ${D}${sbindir}/in.rshd |
| 87 | cp ${WORKDIR}/rsh.xinetd.inetutils ${D}/${sysconfdir}/xinetd.d/rsh |
| 88 | fi |
| 89 | if [ -e ${D}${libexecdir}/talkd ]; then |
| 90 | mv ${D}${libexecdir}/talkd ${D}${sbindir}/in.talkd |
| 91 | fi |
| 92 | mv ${D}${libexecdir}/uucpd ${D}${sbindir}/in.uucpd |
| 93 | mv ${D}${libexecdir}/* ${D}${bindir}/ |
| 94 | cp ${WORKDIR}/telnet.xinetd.inetutils ${D}/${sysconfdir}/xinetd.d/telnet |
| 95 | cp ${WORKDIR}/tftpd.xinetd.inetutils ${D}/${sysconfdir}/xinetd.d/tftpd |
| 96 | |
| 97 | sed -e 's,@SBINDIR@,${sbindir},g' -i ${D}/${sysconfdir}/xinetd.d/* |
| 98 | if [ -e ${D}${libdir}/charset.alias ]; then |
| 99 | rm -rf ${D}${libdir}/charset.alias |
| 100 | fi |
| 101 | rm -rf ${D}${libexecdir}/ |
| 102 | # remove usr/lib if empty |
| 103 | rmdir ${D}${libdir} || true |
| 104 | } |
| 105 | |
| 106 | PACKAGES =+ "${PN}-ping ${PN}-ping6 ${PN}-hostname ${PN}-ifconfig \ |
| 107 | ${PN}-tftp ${PN}-logger ${PN}-traceroute ${PN}-syslogd \ |
| 108 | ${PN}-ftp ${PN}-ftpd ${PN}-tftpd ${PN}-telnet ${PN}-telnetd ${PN}-inetd \ |
| 109 | ${PN}-rsh ${PN}-rshd" |
| 110 | |
| 111 | # The packages tftpd, telnetd and rshd conflict with the ones |
| 112 | # provided by netkit, so add the corresponding -dbg packages |
| 113 | # for them to avoid the confliction between the dbg package |
| 114 | # of inetutils and netkit. |
| 115 | PACKAGES =+ "${PN}-tftpd-dbg ${PN}-telnetd-dbg ${PN}-rshd-dbg" |
| 116 | NOAUTOPACKAGEDEBUG = "1" |
| 117 | |
| 118 | ALTERNATIVE_PRIORITY = "79" |
| 119 | ALTERNATIVE_${PN} = "whois" |
| 120 | ALTERNATIVE_LINK_NAME[uucpd] = "${sbindir}/in.uucpd" |
| 121 | |
| 122 | ALTERNATIVE_PRIORITY_${PN}-logger = "60" |
| 123 | ALTERNATIVE_${PN}-logger = "logger" |
| 124 | ALTERNATIVE_${PN}-syslogd = "syslogd" |
| 125 | ALTERNATIVE_LINK_NAME[syslogd] = "${base_sbindir}/syslogd" |
| 126 | |
| 127 | ALTERNATIVE_${PN}-ftp = "ftp" |
| 128 | ALTERNATIVE_${PN}-ftpd = "ftpd" |
| 129 | ALTERNATIVE_${PN}-tftp = "tftp" |
| 130 | ALTERNATIVE_${PN}-tftpd = "tftpd" |
| 131 | ALTERNATIVE_LINK_NAME[tftpd] = "${sbindir}/tftpd" |
| 132 | ALTERNATIVE_TARGET[tftpd] = "${sbindir}/in.tftpd" |
| 133 | |
| 134 | ALTERNATIVE_${PN}-telnet = "telnet" |
| 135 | ALTERNATIVE_${PN}-telnetd = "telnetd" |
| 136 | ALTERNATIVE_LINK_NAME[telnetd] = "${sbindir}/telnetd" |
| 137 | ALTERNATIVE_TARGET[telnetd] = "${sbindir}/in.telnetd" |
| 138 | |
| 139 | ALTERNATIVE_${PN}-inetd= "inetd" |
| 140 | ALTERNATIVE_${PN}-traceroute = "traceroute" |
| 141 | |
| 142 | ALTERNATIVE_${PN}-hostname = "hostname" |
| 143 | ALTERNATIVE_LINK_NAME[hostname] = "${base_bindir}/hostname" |
| 144 | |
| 145 | ALTERNATIVE_${PN}-doc = "hostname.1 dnsdomainname.1 logger.1 syslogd.8" |
| 146 | ALTERNATIVE_LINK_NAME[hostname.1] = "${mandir}/man1/hostname.1" |
| 147 | ALTERNATIVE_LINK_NAME[dnsdomainname.1] = "${mandir}/man1/dnsdomainname.1" |
| 148 | ALTERNATIVE_LINK_NAME[logger.1] = "${mandir}/man1/logger.1" |
| 149 | ALTERNATIVE_LINK_NAME[syslogd.8] = "${mandir}/man8/syslogd.8" |
| 150 | |
| 151 | ALTERNATIVE_${PN}-ifconfig = "ifconfig" |
| 152 | ALTERNATIVE_LINK_NAME[ifconfig] = "${base_sbindir}/ifconfig" |
| 153 | |
| 154 | ALTERNATIVE_${PN}-ping = "ping" |
| 155 | ALTERNATIVE_LINK_NAME[ping] = "${base_bindir}/ping" |
| 156 | |
| 157 | ALTERNATIVE_${PN}-ping6 = "${@bb.utils.filter('PACKAGECONFIG', 'ping6', d)}" |
| 158 | ALTERNATIVE_LINK_NAME[ping6] = "${base_bindir}/ping6" |
| 159 | |
| 160 | |
| 161 | FILES_${PN}-dbg += "${base_bindir}/.debug ${base_sbindir}/.debug ${bindir}/.debug ${sbindir}/.debug" |
| 162 | FILES_${PN}-ping = "${base_bindir}/ping.${BPN}" |
| 163 | FILES_${PN}-ping6 = "${base_bindir}/ping6.${BPN}" |
| 164 | FILES_${PN}-hostname = "${base_bindir}/hostname.${BPN}" |
| 165 | FILES_${PN}-ifconfig = "${base_sbindir}/ifconfig.${BPN}" |
| 166 | FILES_${PN}-traceroute = "${bindir}/traceroute.${BPN}" |
| 167 | FILES_${PN}-logger = "${bindir}/logger.${BPN}" |
| 168 | |
| 169 | FILES_${PN}-syslogd = "${base_sbindir}/syslogd.${BPN}" |
| 170 | RCONFLICTS_${PN}-syslogd = "rsyslog busybox-syslog sysklogd syslog-ng" |
| 171 | |
| 172 | FILES_${PN}-ftp = "${bindir}/ftp.${BPN}" |
| 173 | |
| 174 | FILES_${PN}-tftp = "${bindir}/tftp.${BPN}" |
| 175 | FILES_${PN}-telnet = "${bindir}/telnet.${BPN}" |
| 176 | |
| 177 | # We make us of RCONFLICTS / RPROVIDES here rather than using the normal |
| 178 | # alternatives method as this leads to packaging QA issues when using |
| 179 | # musl as that library does not provide what these applications need to |
| 180 | # build. |
| 181 | FILES_${PN}-rsh = "${bindir}/rsh ${bindir}/rlogin ${bindir}/rexec ${bindir}/rcp" |
| 182 | RCONFLICTS_${PN}-rsh += "netkit-rsh-client" |
| 183 | RPROVIDES_${PN}-rsh = "rsh" |
| 184 | |
| 185 | FILES_${PN}-rshd = "${sbindir}/in.rshd ${sbindir}/in.rlogind ${sbindir}/in.rexecd \ |
| 186 | ${sysconfdir}/xinetd.d/rsh ${sysconfdir}/xinetd.d/rlogin ${sysconfdir}/xinetd.d/rexec" |
| 187 | FILES_${PN}-rshd-dbg = "${sbindir}/.debug/in.rshd ${sbindir}/.debug/in.rlogind ${sbindir}/.debug/in.rexecd" |
| 188 | RDEPENDS_${PN}-rshd += "xinetd tcp-wrappers" |
| 189 | RCONFLICTS_${PN}-rshd += "netkit-rshd-server" |
| 190 | RPROVIDES_${PN}-rshd = "rshd" |
| 191 | |
| 192 | FILES_${PN}-ftpd = "${bindir}/ftpd.${BPN}" |
| 193 | FILES_${PN}-ftpd-dbg = "${bindir}/.debug/ftpd.${BPN}" |
| 194 | RDEPENDS_${PN}-ftpd += "xinetd" |
| 195 | |
| 196 | FILES_${PN}-tftpd = "${sbindir}/in.tftpd ${sysconfdir}/xinetd.d/tftpd" |
| 197 | FILES_${PN}-tftpd-dbg = "${sbindir}/.debug/in.tftpd" |
| 198 | RCONFLICTS_${PN}-tftpd += "netkit-tftpd" |
| 199 | RDEPENDS_${PN}-tftpd += "xinetd" |
| 200 | |
| 201 | FILES_${PN}-telnetd = "${sbindir}/in.telnetd ${sysconfdir}/xinetd.d/telnet" |
| 202 | FILES_${PN}-telnetd-dbg = "${sbindir}/.debug/in.telnetd" |
| 203 | RCONFLICTS_${PN}-telnetd += "netkit-telnetd" |
| 204 | RPROVIDES_${PN}-telnetd = "telnetd" |
| 205 | RDEPENDS_${PN}-telnetd += "xinetd" |
| 206 | |
| 207 | FILES_${PN}-inetd = "${bindir}/inetd.${BPN}" |
| 208 | |
| 209 | RDEPENDS_${PN} = "xinetd" |