Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "The extensible, standards compliant build backend used by Hatch" |
| 2 | HOMEPAGE = "https://hatch.pypa.io/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9" |
| 5 | |
| 6 | inherit pypi python_hatchling |
| 7 | |
| 8 | DEPENDS += "python3-pluggy-native python3-pathspec-native python3-packaging-native python3-editables-native" |
| 9 | DEPENDS:remove:class-native = "python3-hatchling-native" |
| 10 | |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "f8d275a2cc720735286b7c2e2bc35da05761e6d3695c2fa416550395f10c53c7" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | do_compile:prepend() { |
| 14 | export PYTHONPATH=src |
| 15 | } |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |