Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | require recipes-extended/newt/libnewt_${PV}.bb |
| 2 | |
| 3 | SUMMARY .= " - python" |
| 4 | DEPENDS = "libnewt python3" |
| 5 | RDEPENDS_${PN} += "python3-core" |
| 6 | |
| 7 | inherit python3native python3-dir |
| 8 | |
| 9 | EXTRA_OECONF += "--with-python" |
| 10 | EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}" |
| 11 | |
| 12 | |
| 13 | do_compile () { |
| 14 | VERSION="$(sed -n 's/^VERSION = //p' Makefile)" |
| 15 | oe_runmake _snack.so |
| 16 | } |
| 17 | |
| 18 | do_install () { |
| 19 | install -d ${D}${PYTHON_SITEPACKAGES_DIR} |
| 20 | install -m 0755 ${PYTHON_DIR}/_snack.so ${D}${PYTHON_SITEPACKAGES_DIR}/ |
| 21 | install -m 0644 snack.py ${D}${PYTHON_SITEPACKAGES_DIR}/ |
| 22 | } |
| 23 | |
| 24 | PACKAGES_remove = "whiptail" |
| 25 | |
| 26 | FILES_${PN} = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 27 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | BBCLASSEXTEND = "native nativesdk" |