blob: 5372ac0ff12f91c47c4597a81891145afbb2cd09 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>"
2DESCRIPTION = "\
3The PyMongo distribution contains tools for interacting with MongoDB \
4database from Python. The bson package is an implementation of the BSON \
5format for Python. The pymongo package is a native Python driver for \
6MongoDB. The gridfs package is a gridfs implementation on top of pymongo."
7HOMEPAGE = "http://github.com/mongodb/mongo-python-driver"
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
Andrew Geissler72956ed2021-01-08 16:11:14 -060011SRC_URI[sha256sum] = "c2b67881392a9e85aa108e75f62cdbe372d5a3f17ea5f8d3436dcf4662052f14"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13inherit pypi setuptools3
14
15PACKAGES =+ "${PYTHON_PN}-bson"
16
17FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*"
18
19RDEPENDS_${PYTHON_PN}-bson += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-json \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-numbers \
24 ${PYTHON_PN}-threading \
25"
26
27RDEPENDS_${PN} += " \
28 ${PYTHON_PN}-bson \
29 ${PYTHON_PN}-pprint \
30"