blob: c39d6c6e37dcc2fd7bedb3190e7f3a6bb4e1bd96 [file] [log] [blame]
Patrick Williams169d7bc2024-01-05 11:33:25 -06001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7inherit python_pyo3 python_setuptools_build_meta
8
9DEPENDS += "python3-maturin-native"
10
11python_maturin_do_configure() {
12 python_pyo3_do_configure
13 cargo_common_do_configure
14 python_pep517_do_configure
15}
16
17EXPORT_FUNCTIONS do_configure