blob: 247a1fcbb206999fc65a0e1548682376dca0d969 [file] [log] [blame]
Andrew Geissler8f840682023-07-21 09:09:43 -05001SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "https://www.kraxel.org/blog/linux/fbida/"
Andrew Geissler8f840682023-07-21 09:09:43 -05005SECTION = "utils"
6
7LICENSE = "GPL-2.0-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39"
9
10DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman udev libinput cairo"
11
Patrick Williams73bd93f2024-02-20 08:07:48 -060012PV = "2.14+git"
Andrew Geissler8f840682023-07-21 09:09:43 -050013SRC_URI = "git://github.com/kraxel/fbida;protocol=https;branch=master \
14 file://fix-preprocessor.patch \
15 file://support-jpeg-turbo.patch \
16 file://fbida-gcc10.patch \
17 file://0001-meson.build-install-fbgs-shell-script.patch \
18 file://0002-meson.build-add-features-options-for-png-gif-tiff-we.patch \
19 file://0003-meson.build-do-not-require-xkbcommon.patch \
20 file://0001-meson.build-make-fbpdf-build-optional.patch \
21 file://0001-fbida-Include-missing-sys-types.h.patch \
22"
23SRCREV = "eb769e3d7f4a073d4c37ed524ebd5017c6a578f5"
24S = "${WORKDIR}/git"
25
26inherit meson pkgconfig features_check
27
28# Depends on libepoxy
29REQUIRED_DISTRO_FEATURES = "opengl"
30
31PACKAGECONFIG ??= "gif png pdf"
32PACKAGECONFIG[gif] = "-Dgif=enabled,-Dgif=disabled,giflib"
33PACKAGECONFIG[png] = "-Dpng=enabled,-Dpng=disabled,libpng"
34PACKAGECONFIG[tiff] = "-Dtiff=enabled,-Dtiff=disabled,tiff"
35PACKAGECONFIG[motif] = "-Dmotif=enabled,-Dmotif=disabled,libx11 libxext libxpm libxt openmotif"
36PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,libwebp"
37PACKAGECONFIG[pdf] = "-Dpdf=enabled,-Dpdf=disabled,poppler libepoxy"
38
39CFLAGS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', '-DEGL_NO_X11=1', d)}"
40
41RDEPENDS:${PN} = "ttf-dejavu-sans-mono"