blob: 91b02ea0170366f9a177ea1506e4c89057023f11 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=b22dc6b663b9175820e5e03337c7596b"
7
Patrick Williamsf52e3dd2024-01-26 13:04:43 -06008SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
11 file://run-ptest \
12 "
13SRCREV ?= "da59ad000d1405eaecd557175e29083a87d19f7c"
14
15inherit setuptools3 ptest
16
17PIP_INSTALL_PACKAGE = "Pillow"
18PIP_INSTALL_DIST_PATH = "${S}/dist"
19
20DEPENDS += " \
21 zlib \
22 jpeg \
23 tiff \
24 freetype \
25 lcms \
26 openjpeg \
27"
28
29RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060030 python3-misc \
31 python3-logging \
32 python3-numbers \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060033 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcb', '', d)} \
34"
35
36RDEPENDS:${PN}-ptest += " \
37 bash \
38 ghostscript \
39 jpeg-tools \
40 libwebp \
Patrick Williams73bd93f2024-02-20 08:07:48 -060041 python3-core \
42 python3-image \
43 python3-mmap \
44 python3-pytest \
45 python3-pytest-timeout \
46 python3-resource \
47 python3-unittest-automake-output \
48 python3-unixadmin\
Patrick Williamsac13d5f2023-11-24 18:59:46 -060049 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
50"
51
52CVE_PRODUCT = "pillow"
53
54S = "${WORKDIR}/git"
55
56RPROVIDES:${PN} += "python3-imaging"
57
58do_install_ptest() {
59 install -d ${D}${PTEST_PATH}/Tests
60 cp -rf ${S}/Tests ${D}${PTEST_PATH}/
61}
62
63BBCLASSEXTEND = "native"