blob: 19c95b374a942a8ecda17d18f117a8caf2d05147 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
2HOMEPAGE = "https://github.com/platformdirs/platformdirs"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
5
6SRC_URI += " \
7 file://run-ptest \
8"
9
Patrick Williams73bd93f2024-02-20 08:07:48 -060010SRC_URI[sha256sum] = "ef0cc731df711022c174543cb70a9b5bd22e5a9337c8624ef2c2ceb8ddad8768"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060011
12inherit pypi python_hatchling ptest
13
14DEPENDS += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-hatch-vcs-native \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060016"
17
18RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-appdirs \
20 python3-covdefaults \
21 python3-pytest \
22 python3-pytest-cov \
23 python3-pytest-mock \
24 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060025"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}
29 cp -rf ${S}/tests ${D}${PTEST_PATH}/
30}
31
32BBCLASSEXTEND = "native nativesdk"