blob: 4abe167f7bd4d12c48d79f637f8b885bedf36097 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format"
2HOMEPAGE = "https://github.com/frederickjansen/polyline"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1fb8d1dc685695195bb3c1e48adfef48"
5
6SRC_URI[sha256sum] = "74cb5cea098dddf09d1a5a1f17af9184d371cbf3e9723de0194e530ec39ca1f6"
7
8inherit pypi python_setuptools_build_meta ptest
9
10RDEPENDS:${PN} += "python3-six"
11
12BBCLASSEXTEND = "native nativesdk"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060019 python3-pytest \
20 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060021"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/test
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/test/
26}