blob: be9ce005eababb5ed8e8d9f1d9f59e758177e88c [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b"
5
6DEPENDS += "python3-setuptools-scm-native"
7
8SRC_URI[sha256sum] = "0379d6cf1ff987cd421609a264ce025e74f346e3e145dd106c0cc2e3ec3f99a9"
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14inherit pypi python_setuptools_build_meta ptest
15
16RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060017 python3-pytest \
18 python3-unittest-automake-output \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060019"
20
21do_install_ptest() {
22 install -d ${D}${PTEST_PATH}/tests
23 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
24}