Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Test vectors for the cryptography package." |
| 2 | HOMEPAGE = "https://cryptography.io/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "Apache-2.0 | BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8c3617db4fb6fae01f1d253ab91511e4 \ |
| 6 | file://LICENSE.APACHE;md5=4e168cce331e5c827d4c2b68a6200e1b \ |
| 7 | file://LICENSE.BSD;md5=5ae30ba4123bc4f2fa49aa0b0dce887b" |
| 8 | |
| 9 | # NOTE: Make sure to keep this recipe at the same version as python3-cryptography |
| 10 | # Upgrade both recipes at the same time |
| 11 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 12 | SRC_URI[sha256sum] = "adcdccf5d9ee661a9602ad21d2525f678ba07a6e768ce79835994e208bab0e16" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 13 | |
| 14 | PYPI_PACKAGE = "cryptography_vectors" |
| 15 | |
| 16 | inherit pypi python_setuptools_build_meta |
| 17 | |
| 18 | DEPENDS += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame^] | 19 | python3-cryptography \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 20 | " |
| 21 | |
| 22 | do_install:append () { |
| 23 | # Remove the sha256 checksum lines for pycache files |
| 24 | sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |
| 28 | |
| 29 | UPSTREAM_CHECK_REGEX = "" |
Patrick Williams | da29531 | 2023-12-05 16:48:56 -0600 | [diff] [blame] | 30 | |
| 31 | RECIPE_NO_UPDATE_REASON = "Must be updated in sync with python3-cryptography." |