William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 1 | SUMMARY = "VCD (Value Change Dump) file waveform viewer" |
| 2 | DESCRIPTION = "gtkwave is a viewer for VCD (Value Change Dump) files which are usually created by digital circuit simulators. (These files have no connection to video CDs!) " |
| 3 | HOMEPAGE = "http://gtkwave.sourceforge.net/" |
| 4 | |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e" |
| 7 | |
| 8 | SRC_URI = "http://gtkwave.sourceforge.net/gtkwave-gtk3-${PV}.tar.gz" |
| 9 | SRC_URI[sha256sum] = "35461eccd9b8b4470caa78ab9a8f14ecacbcc9eff63033d8dce58093e786deb7" |
| 10 | S = "${WORKDIR}/${BPN}-gtk3-${PV}" |
| 11 | |
| 12 | DEPENDS = " \ |
| 13 | gperf-native \ |
| 14 | gtk+3 \ |
| 15 | gdk-pixbuf \ |
| 16 | tcl \ |
| 17 | tk \ |
| 18 | bzip2 \ |
| 19 | xz \ |
| 20 | pango \ |
| 21 | zlib \ |
| 22 | " |
| 23 | |
| 24 | inherit pkgconfig autotools gettext texinfo mime mime-xdg |
| 25 | |
| 26 | inherit features_check |
| 27 | # depends on gtk+3 which has this restriction |
| 28 | # ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 29 | # but https://github.com/gtkwave/gtkwave/blob/f9d82a82aa3ddc30ca47984278371f62c9a3bd81/gtkwave3-gtk3/src/gtk23compat.h#L10 |
| 30 | # explicitly includes gdk/gdkwayland.h for gtk-3.22.26 and newer (oe-core currently has 3.24.29) |
| 31 | # and it needs x11 as well for tk dependency (so it happends to be both GTK3DISTROFEATURES instead of either of them) |
| 32 | REQUIRED_DISTRO_FEATURES = "wayland x11" |
| 33 | |
| 34 | EXTRA_OECONF = " \ |
| 35 | --enable-gtk3 \ |
| 36 | --with-tcl=${STAGING_BINDIR_CROSS} \ |
| 37 | --with-tk=${STAGING_BINDIR_CROSS} \ |
| 38 | --with-tirpc \ |
| 39 | --disable-mime-update \ |
| 40 | " |
| 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | FILES:${PN} = "${bindir} ${datadir}" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 43 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 44 | RDEPENDS:${PN} += "tk-lib" |