Brad Bishop | bec4ebc | 2022-08-03 09:55:16 -0400 | [diff] [blame] | 1 | require gem5-source_20.inc |
| 2 | |
| 3 | SRC_URI += "file://0001-dev-arm-SMMUv3-enable-interrupt-interface.patch" |
| 4 | |
| 5 | BPN = "gem5-aarch64-native" |
| 6 | |
| 7 | require gem5-aarch64-native.inc |
| 8 | require gem5-native.inc |
| 9 | |
| 10 | # Get rid of compiler errors when building protobuf |
| 11 | GEM5_SCONS_ARGS:append = " CCFLAGS_EXTRA='-Wno-error=unused-variable' --verbose" |
| 12 | |
| 13 | # Get rid of linker errors and have a faster link process |
| 14 | GEM5_SCONS_ARGS:append = " LDFLAGS_EXTRA='${BUILD_LDFLAGS}' \ |
| 15 | MARSHAL_LDFLAGS_EXTRA='${BUILD_LDFLAGS}' --force-lto " |
| 16 | |
| 17 | do_compile:prepend() { |
| 18 | # Gem5 expect to have python in the path (can be python2 or 3) |
| 19 | # Create a link named python to python3 |
| 20 | real=$(which ${PYTHON}) |
| 21 | ln -snf $real $(dirname $real)/python |
| 22 | } |