blob: d2ea14c79911aee1f69da6d3276d36d487f5e5bc [file] [log] [blame]
Andrei Kartashev0f66db42021-08-17 21:47:15 +03001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
Alexander Filippov000c8ff2020-06-10 17:55:57 +03002
3inherit systemd
4
Andrei Kartashev0f66db42021-08-17 21:47:15 +03005RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils}"
6SYSTEMD_SERVICE:${PN} = "${BPN}.service"
7SRC_URI:append = " \
Alexander Filippov000c8ff2020-06-10 17:55:57 +03008 file://${BPN}-set-device-id.sh \
9 file://${BPN}.service \
10"
11
12S = "${WORKDIR}"
Andrei Kartashev0f66db42021-08-17 21:47:15 +030013do_install:append() {
Alexander Filippov000c8ff2020-06-10 17:55:57 +030014 install -d ${D}${bindir} ${D}${systemd_system_unitdir}
15 install ${BPN}-set-device-id.sh ${D}${bindir}/
16 install -m 0644 ${BPN}.service ${D}${systemd_system_unitdir}/
17}
18
Andrei Kartashev0f66db42021-08-17 21:47:15 +030019FILES:${PN}:append = " \
Alexander Filippov000c8ff2020-06-10 17:55:57 +030020 ${bindir}/${BPN}-set-device-id.sh \
21"