blob: ec16f078f2c7dc6b7ec43eb777ecf19fb08a4631 [file] [log] [blame]
Willy Tu74a3a8a2021-02-10 09:52:53 -08001PR = "r1"
2
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8RDEPENDS_${PN} += "sslh"
9
10SRC_URI_append = " \
11 file://sslh.service \
12 file://sslh.socket \
13"
14
15SYSTEMD_SERVICE_${PN} += "sslh.service"
16SYSTEMD_SERVICE_${PN} += "sslh.socket"
17
18do_install() {
19 # Install service definitions
20 install -d -m 0755 ${D}${systemd_system_unitdir}
21 install -m 0644 ${WORKDIR}/sslh.service ${D}${systemd_system_unitdir}
22 install -m 0644 ${WORKDIR}/sslh.socket ${D}${systemd_system_unitdir}
23}