blob: d77252beacfeee54db52df51d6d673ba4715b703 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Unified diff parsing/metadata extraction library"
2HOMEPAGE = "http://github.com/matiasb/python-unidiff"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=4c434b08ef42fea235bb019b5e5a97b3"
5
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05006SRC_URI[sha256sum] = "2e5f0162052248946b9f0970a40e9e124236bf86c82b70821143a6fc1dea2574"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-pytest \
16 python3-unittest-automake-output \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060025 python3-codecs \
26 python3-io \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000027"