blob: 1de95c8e5243529030c4bbb346499ef3f5413430 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "Bmap-tools - tools to generate block map (AKA bmap) and flash images using \
3bmap. Bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/01org/bmap-tools"
8SECTION = "console/utils"
9LICENSE = "GPL-2.0-only"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050012SRC_URI = "git://github.com/intel/${BPN};branch=main;protocol=https"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000013
14SRCREV = "c0673962a8ec1624b5189dc1d24f33fe4f06785a"
15S = "${WORKDIR}/git"
16BASEVER = "3.6"
Andrew Geissler5082cc72023-09-11 08:41:39 -040017PV = "${BASEVER}+git"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000018
19UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
20
21# Need df from coreutils
22RDEPENDS:${PN} = "python3-core python3-compression python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
23
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024inherit setuptools3
25
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000026BBCLASSEXTEND = "native nativesdk"