blob: 266573681e8168130f8b68cd8dc0c0ae7fb6f35d [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Fetchmail retrieves mail from remote mail servers and forwards it via SMTP"
2HOMEPAGE = "http://www.fetchmail.info/"
3DESCRIPTION = "Fetchmail is a full-featured, robust, well-documented remote-mail retrieval \
4and forwarding utility intended to be used over on-demand TCP/IP links (such as SLIP or PPP \
5connections). It supports every remote-mail protocol now in use on the Internet: POP2, POP3, \
6RPOP, APOP, KPOP, all flavors of IMAP, ETRN, and ODMR. It can even support IPv6 and IPSEC."
7SECTION = "mail"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008LICENSE = "GPL-2.0-only & MIT"
Andrew Geissler595f6302022-01-24 19:11:47 +00009LIC_FILES_CHKSUM = "file://COPYING;md5=c3a05d9b9d3784c824c9b92a648e1353"
10
11DEPENDS = "openssl"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz \
14 "
15SRC_URI[sha256sum] = "5f7a5e13731431134a2ca535bbced7adc666d3aeb93169a0830945d91f492300"
16
17inherit autotools gettext pkgconfig python3-dir python3native
18
19EXTRA_OECONF = "--with-ssl=${STAGING_DIR_HOST}${prefix}"
20
Patrick Williams7784c422022-11-17 07:29:11 -060021do_install:append() {
22 sed -i 's,${RECIPE_SYSROOT_NATIVE},,g' ${D}${bindir}/fetchmailconf
23}
24
Andrew Geissler595f6302022-01-24 19:11:47 +000025PACKAGES =+ "fetchmail-python"
26FILES:fetchmail-python = "${libdir}/${PYTHON_DIR}/*"