blob: 11f5451609b46bd93c396318d3e8b756c49ef68d [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=ad081a0aede51e89f8da13333a8fb849"
7
Patrick Williams7784c422022-11-17 07:29:11 -06008SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
Andrew Geissler9aee5002022-03-30 16:27:02 +00009 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050011 "
Andrew Geissler9aee5002022-03-30 16:27:02 +000012SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
13
14inherit setuptools3
15
16PIP_INSTALL_PACKAGE = "Pillow"
17PIP_INSTALL_DIST_PATH = "${S}/dist"
18
19DEPENDS += " \
20 zlib \
21 jpeg \
22 tiff \
23 freetype \
24 lcms \
25 openjpeg \
26"
27
28RDEPENDS:${PN} += " \
29 ${PYTHON_PN}-misc \
30 ${PYTHON_PN}-logging \
31 ${PYTHON_PN}-numbers \
32"
33
34CVE_PRODUCT = "pillow"
35
36S = "${WORKDIR}/git"
37
38RPROVIDES:${PN} += "python3-imaging"
39
40BBCLASSEXTEND = "native"
41
Patrick Williams7784c422022-11-17 07:29:11 -060042SRCREV = "d594f4cb8dc47fb0c69ae58d9fff86faae4515bd"