blob: 93e185f2c98071da5cb20a7d09f2252a9bda60f1 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001#
2# Copyright OpenEmbedded Contributors
3#
4# SPDX-License-Identifier: MIT
5#
6
7##
8## Purpose:
9## This class is used by any recipes that are built using
10## Cargo.
11
12inherit cargo_common
13inherit rust-target-config
14
15# the binary we will use
16CARGO = "cargo"
17
18# We need cargo to compile for the target
19BASEDEPENDS:append = " cargo-native"
20
21# Ensure we get the right rust variant
22DEPENDS:append:class-target = " rust-native ${RUSTLIB_DEP}"
23DEPENDS:append:class-nativesdk = " rust-native ${RUSTLIB_DEP}"
24DEPENDS:append:class-native = " rust-native"
25
26# Enable build separation
27B = "${WORKDIR}/build"
28
29# In case something fails in the build process, give a bit more feedback on
30# where the issue occured
31export RUST_BACKTRACE = "1"
32
33# The directory of the Cargo.toml relative to the root directory, per default
34# assume there's a Cargo.toml directly in the root directory
35CARGO_SRC_DIR ??= ""
36
37# The actual path to the Cargo.toml
38MANIFEST_PATH ??= "${S}/${CARGO_SRC_DIR}/Cargo.toml"
39
40RUSTFLAGS ??= ""
41BUILD_MODE = "${@['--release', ''][d.getVar('DEBUG_BUILD') == '1']}"
42CARGO_BUILD_FLAGS = "-v --target ${RUST_HOST_SYS} ${BUILD_MODE} --manifest-path=${MANIFEST_PATH}"
43
44# This is based on the content of CARGO_BUILD_FLAGS and generally will need to
45# change if CARGO_BUILD_FLAGS changes.
46BUILD_DIR = "${@['release', 'debug'][d.getVar('DEBUG_BUILD') == '1']}"
47CARGO_TARGET_SUBDIR="${RUST_HOST_SYS}/${BUILD_DIR}"
48oe_cargo_build () {
49 export RUSTFLAGS="${RUSTFLAGS}"
50 bbnote "Using rust targets from ${RUST_TARGET_PATH}"
51 bbnote "cargo = $(which ${CARGO})"
Patrick Williams92b42cb2022-09-03 06:53:57 -050052 bbnote "${CARGO} build ${CARGO_BUILD_FLAGS} $@"
53 "${CARGO}" build ${CARGO_BUILD_FLAGS} "$@"
54}
55
56do_compile[progress] = "outof:\s+(\d+)/(\d+)"
57cargo_do_compile () {
58 oe_cargo_fix_env
59 oe_cargo_build
60}
61
62cargo_do_install () {
63 local have_installed=false
64 for tgt in "${B}/target/${CARGO_TARGET_SUBDIR}/"*; do
65 case $tgt in
66 *.so|*.rlib)
67 install -d "${D}${rustlibdir}"
68 install -m755 "$tgt" "${D}${rustlibdir}"
69 have_installed=true
70 ;;
71 *examples)
72 if [ -d "$tgt" ]; then
73 for example in "$tgt/"*; do
74 if [ -f "$example" ] && [ -x "$example" ]; then
75 install -d "${D}${bindir}"
76 install -m755 "$example" "${D}${bindir}"
77 have_installed=true
78 fi
79 done
80 fi
81 ;;
82 *)
83 if [ -f "$tgt" ] && [ -x "$tgt" ]; then
84 install -d "${D}${bindir}"
85 install -m755 "$tgt" "${D}${bindir}"
86 have_installed=true
87 fi
88 ;;
89 esac
90 done
91 if ! $have_installed; then
92 die "Did not find anything to install"
93 fi
94}
95
96EXPORT_FUNCTIONS do_compile do_install