blob: b5bfc6e34cd4869d34ec1dd530162cf563d6d6d1 [file] [log] [blame]
Patrick Williams7784c422022-11-17 07:29:11 -06001SUMMARY = "Musl libc unit tests"
2HOMEPAGE = "https://wiki.musl-libc.org/libc-test.html"
3DESCRIPTION = "libc-test is a collection of unit tests to measure the \
4correctness and robustness of a C/POSIX standard library implementation. It is \
5developed as part of the musl project."
6SECTION = "tests"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=43ed1245085be90dc934288117d55a3b"
9
10inherit ptest
11
12SRCREV = "18e28496adee3d84fefdda6efcb9c5b8996a2398"
13SRC_URI = " \
14 git://repo.or.cz/libc-test;branch=master \
15 file://run-ptest \
16"
17
18PV = "0+git${SRCPV}"
19
20S = "${WORKDIR}/git"
21
22# libc-test 'make' or 'make run' command is designed to build and run tests. It
23# reports both build and test failures. The commands should be run on target.
24do_compile() {
25 :
26}
27
28RDEPENDS:${PN} = " \
29 bash \
30 grep \
31 musl \
32 packagegroup-core-buildessential \
33"
34
35RDEPENDS:${PN}-ptest = " \
36 ${PN} \
37 sed \
38"
39
40install_path = "/opt/${PN}"
41FILES:${PN} += "${install_path}/*"
42
43do_install () {
44 install -d ${D}${install_path}/
45 cp ${S}/Makefile ${D}${install_path}
46 cp ${S}/config.mak.def ${D}${install_path}/config.mak
47 cp -r ${S}/src ${D}${install_path}
48}
49
50COMPATIBLE_HOST = "null"
51COMPATIBLE_HOST:libc-musl = "(.*)"