blob: 27ec7560ea703e3916a92d2466bb995774d74bb6 [file] [log] [blame]
Patrick Williams7784c422022-11-17 07:29:11 -06001SUMMARY = "Backported and Experimental Type Hints for Python 3.7+"
2DESCRIPTION = "The typing_extensions module serves two related purposes:\
3\
4* Enable use of new type system features on older Python versions. For \
5 example, typing.TypeGuard is new in Python 3.10, but typing_extensions \
6 allows users on previous Python versions to use it too.\
7* Enable experimentation with new type system PEPs before they are accepted \
8 and added to the typing module."
9HOMEPAGE = "https://github.com/python/typing_extensions"
10BUGTRACKER = "https://github.com/python/typing_extensions/issues"
11SECTIONS = "libs"
12LICENSE = "PSF-2.0"
13LIC_FILES_CHKSUM = "file://LICENSE;md5=f16b323917992e0f8a6f0071bc9913e2"
14
15# The name on PyPi is slightly different.
16PYPI_PACKAGE = "typing_extensions"
17
18SRC_URI[sha256sum] = "1511434bb92bf8dd198c12b1cc812e800d4181cfcb867674e0f8279cc93087aa"
19
20inherit pypi python_flit_core
21
22UPSTREAM_CHECK_REGEX = "/typing-extensions/(?P<pver>(\d+[\.\-_]*)+)/"
23
24BBCLASSEXTEND = "native nativesdk"