Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "High-level GnuPG encryption/signing API" |
| 2 | DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management" |
| 3 | HOMEPAGE = "http://www.gnupg.org/gpgme.html" |
| 4 | BUGTRACKER = "https://bugs.g10code.com/gnupg/index" |
| 5 | |
| 6 | LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 8 | file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \ |
| 9 | file://src/gpgme.h.in;endline=23;md5=2f0bf06d1c7dcb28532a9d0f94a7ca1d \ |
| 10 | file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d" |
| 11 | |
| 12 | UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html" |
| 13 | SRC_URI = "${GNUPG_MIRROR}/gpgme/${BP}.tar.bz2 \ |
| 14 | file://0001-Revert-build-Make-gpgme.m4-use-gpgrt-config-with-.pc.patch \ |
| 15 | file://0001-pkgconfig.patch \ |
| 16 | file://0002-gpgme-lang-python-gpg-error-config-should-not-be-use.patch \ |
| 17 | file://0003-Correctly-install-python-modules.patch \ |
| 18 | file://0004-python-import.patch \ |
| 19 | file://0005-gpgme-config-skip-all-lib-or-usr-lib-directories-in-.patch \ |
| 20 | file://0006-fix-build-path-issue.patch \ |
| 21 | file://0007-python-Add-variables-to-tests.patch \ |
| 22 | file://0008-do-not-auto-check-var-PYTHON.patch \ |
| 23 | file://0001-use-closefrom-on-linux-and-glibc-2.34.patch \ |
| 24 | " |
| 25 | |
| 26 | SRC_URI[sha256sum] = "361d4eae47ce925dba0ea569af40e7b52c645c4ae2e65e5621bf1b6cdd8b0e9e" |
| 27 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 28 | PYTHON_DEPS = "${@bb.utils.contains('LANGUAGES', 'python', 'swig-native', '', d)}" |
| 29 | |
| 30 | DEPENDS = "libgpg-error libassuan ${PYTHON_DEPS}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 31 | RDEPENDS:${PN}-cpp += "libstdc++" |
| 32 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 33 | RDEPENDS:python3-gpg += "python3-unixadmin" |
| 34 | |
| 35 | BINCONFIG = "${bindir}/gpgme-config" |
| 36 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 37 | # Default in configure.ac: "cl cpp python qt" |
| 38 | # Supported: "cl cpp python python2 python3 qt" |
| 39 | # python says 'search and find python2 or python3' |
| 40 | |
| 41 | # Building the C++ bindings for native requires a C++ compiler with C++11 |
| 42 | # support. Since these bindings are currently not needed, we can disable them. |
| 43 | DEFAULT_LANGUAGES = "" |
| 44 | DEFAULT_LANGUAGES:class-target = "cpp" |
| 45 | LANGUAGES ?= "${DEFAULT_LANGUAGES} python" |
| 46 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 47 | PYTHON_INHERIT = "${@bb.utils.contains('LANGUAGES', 'python', 'setuptools3-base', '', d)}" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 48 | |
| 49 | EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \ |
| 50 | --disable-gpgconf-test \ |
| 51 | --disable-gpg-test \ |
| 52 | --disable-gpgsm-test \ |
| 53 | --disable-g13-test \ |
| 54 | --disable-lang-python-test \ |
| 55 | ' |
| 56 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 57 | inherit autotools texinfo binconfig-disabled pkgconfig ${PYTHON_INHERIT} python3native multilib_header |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 58 | |
| 59 | export PKG_CONFIG='pkg-config' |
| 60 | |
| 61 | BBCLASSEXTEND = "native nativesdk" |
| 62 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame^] | 63 | PACKAGES =+ "${PN}-cpp python3-gpg" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 64 | |
| 65 | FILES:${PN}-cpp = "${libdir}/libgpgmepp.so.*" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 66 | FILES:python3-gpg = "${PYTHON_SITEPACKAGES_DIR}/*" |
| 67 | FILES:${PN}-dev += "${datadir}/common-lisp/source/gpgme/*" |
| 68 | |
| 69 | CFLAGS:append:libc-musl = " -D__error_t_defined " |
| 70 | do_configure:prepend () { |
| 71 | # Else these could be used in preference to those in aclocal-copy |
| 72 | rm -f ${S}/m4/gpg-error.m4 |
| 73 | rm -f ${S}/m4/libassuan.m4 |
| 74 | rm -f ${S}/m4/python.m4 |
| 75 | } |
| 76 | |
| 77 | do_install:append() { |
| 78 | oe_multilib_header gpgme.h |
| 79 | } |