blob: 6b541700493c11c512ff6d0e03225e8b528cdd55 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1+"
Brad Bishopb809eb92019-09-18 06:27:43 -04004LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005SECTION = "net"
Brad Bishopb809eb92019-09-18 06:27:43 -04006
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007DEPENDS = "file"
8
Brad Bishop779d0ac2019-09-27 08:23:48 -04009SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz \
10 file://fix-build-with-older-gnutls.patch \
11"
Brad Bishopb809eb92019-09-18 06:27:43 -040012SRC_URI[md5sum] = "ce4050e75cc40d68506e2b403e1a76f9"
13SRC_URI[sha256sum] = "4e66d4db1574f4912fbd2690d10d227cc9cc56df6a10aa8f4fc2da75cea7ab1b"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014
15inherit autotools lib_package pkgconfig gettext
16
17CFLAGS += "-pthread -D_REENTRANT"
18
19EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../"
20
21PACKAGECONFIG ?= "curl https"
22PACKAGECONFIG_append_class-target = "\
23 ${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)} \
24"
25PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
26PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
27PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
28
29do_compile_append() {
30 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
31}