Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command" |
| 2 | HOMEPAGE = "http://man-db.nongnu.org/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "man-db is an implementation of the standard Unix documentation system accessed using the man command. It uses a Berkeley DB database in place of the traditional flat-text whatis databases." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LICENSE = "LGPLv2.1 & GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ |
| 6 | file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 7 | |
| 8 | SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz \ |
| 9 | file://99_mandb \ |
| 10 | file://man_db.conf-avoid-multilib-install-file-conflict.patch" |
Andrew Geissler | 9b4d8b0 | 2021-02-19 12:26:16 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "b66c99edfad16ad928c889f87cf76380263c1609323c280b3a9e6963fdb16756" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | DEPENDS = "libpipeline gdbm groff-native base-passwd" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | RDEPENDS:${PN} += "base-passwd" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 15 | PACKAGE_WRITE_DEPS += "base-passwd" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | # | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr' |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | USE_NLS:libc-musl = "no" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | inherit gettext pkgconfig autotools systemd |
| 21 | |
| 22 | EXTRA_OECONF = "--with-pager=less --with-systemdsystemunitdir=${systemd_unitdir}/system" |
| 23 | EXTRA_AUTORECONF += "-I ${S}/gl/m4" |
| 24 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | do_install() { |
| 26 | autotools_do_install |
| 27 | |
| 28 | if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then |
| 29 | install -d ${D}/etc/default/volatiles |
| 30 | install -m 0644 ${WORKDIR}/99_mandb ${D}/etc/default/volatiles |
| 31 | fi |
| 32 | } |
| 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | do_install:append:libc-musl() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | rm -f ${D}${libdir}/charset.alias |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | FILES:${PN} += "${prefix}/lib/tmpfiles.d" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 39 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 40 | FILES:${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | RDEPENDS:${PN} += "groff" |
| 43 | RRECOMMENDS:${PN} += "less" |
| 44 | RPROVIDES:${PN} += " man" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 45 | |
| 46 | def compress_pkg(d): |
| 47 | if bb.utils.contains("INHERIT", "compress_doc", True, False, d): |
| 48 | compress = d.getVar("DOC_COMPRESS") |
| 49 | if compress == "gz": |
| 50 | return "gzip" |
| 51 | elif compress == "bz2": |
| 52 | return "bzip2" |
| 53 | elif compress == "xz": |
| 54 | return "xz" |
| 55 | return "" |
| 56 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 57 | RDEPENDS:${PN} += "${@compress_pkg(d)}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 58 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | SYSTEMD_SERVICE:${PN} = "man-db.timer man-db.service" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 60 | SYSTEMD_AUTO_ENABLE ?= "disable" |