blob: 9d58b9a63f34ffddafd39ba9e29ad6ff98a6aac5 [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001SUMMARY = "File system check utility for OverlayFS"
2HOMEPAGE = "https://github.com/hisilicon/overlayfs-progs"
3LICENSE = "PD"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/PD;md5=b3597d12946881e13cb3b548d1173851"
5
6SRC_URI = "\
7 git://github.com/hisilicon/overlayfs-progs.git;protocol=https;branch=master \
8 file://0001-Makefile-proper-location-of-LDFLAGS.patch \
9"
10
11PV = "1.0+git${SRCPV}"
12SRCREV = "e10ef686570d9c7eff42f52461593a5c15da56bd"
13
14S = "${WORKDIR}/git"
15B = "${S}"
16
17# Required to have the fts.h header for musl
18DEPENDS:append:libc-musl = " fts"
19# Fix the missing fts libs when using musl
20EXTRA_OEMAKE:append:libc-musl = " LDFLAGS='-lfts'"
21
22EXTRA_OEMAKE += "'CC=${CC} -O2' "
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25do_compile () {
26 oe_runmake
27}
28
29do_install () {
30 install -d ${D}${bindir}
31 install -m 0755 ${B}/fsck.overlay ${D}${bindir}
32}