blob: 1ffdcfd0450ac710e74c716e9f1d3a18f7ddaabd [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Common GNOME build files for C++ bindings"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5GNOMEBASEBUILDCLASS = "meson"
6
7inherit gnomebase
8
Andrew Geissler78b72792022-06-14 06:47:25 -05009# All the recipe does is stage python and shell script, some autotools files; nothing is compiled.
10inherit allarch
11
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012SRC_URI[archive.sha256sum] = "e954c09b4309a7ef93e13b69260acdc5738c907477eb381b78bb1e414ee6dbd8"
13SRC_URI += "file://0001-meson.build-do-not-ask-for-python-installation-versi.patch"
14
15BBCLASSEXTEND = "native"
Andrew Geissler78b72792022-06-14 06:47:25 -050016
17# These files aren't very usefull on target image, package them all in nnPN-dev
18FILES:${PN} = ""
19
20FILES:${PN}-dev += " \
21 ${datadir}/${BPN}/build \
22 ${datadir}/${BPN}/doctags \
23 ${datadir}/${BPN}/doctool \
24 ${bindir}/mm-common-get \
25 ${bindir}/mm-common-prepare \
26"
27# ${PN} package is empty, remove the default dependency on it
28RDEPENDS:${PN}-dev = ""