blob: aee6bfe3da1137e792947e631accd89780546a4d [file] [log] [blame]
Andrew Geissler78b72792022-06-14 06:47:25 -05001SUMMARY = "Simple program to read/write from/to any location in memory"
2LICENSE = "GPL-2.0-or-later"
3LIC_FILES_CHKSUM = "file://devmem2.c;endline=38;md5=a9eb9f3890384519f435aedf986297cf"
4
5SRC_URI = "git://github.com/denix0/devmem2.git;protocol=https;branch=main"
6SRCREV = "5b395a946894eb4f4ef5d07c80a50a88573a541e"
7
8S = "${WORKDIR}/git"
9
10CFLAGS += "-DFORCE_STRICT_ALIGNMENT"
11
12do_compile() {
13 ${CC} -o devmem2 devmem2.c ${CFLAGS} ${LDFLAGS}
14}
15
16do_install() {
17 install -d ${D}${bindir}
18 install devmem2 ${D}${bindir}
19}