blob: 1153ea32cea1149f941411c0e12d000cc0e401ed [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Provides both a high- and low-level interface to the HDF5 library from Python."
2HOMEPAGE = "https://www.h5py.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=113251d71fb0384712c719b567261c5c"
6
Andrew Geissler78b72792022-06-14 06:47:25 -05007SRC_URI[sha256sum] = "3fcf37884383c5da64846ab510190720027dca0768def34dd8dcb659dbe5cbf3"
Andrew Geissler9aee5002022-03-30 16:27:02 +00008
9SRC_URI:append = " \
10 file://0001-setup_build.py-avoid-absolute-path.patch \
11 "
12
13inherit pkgconfig pypi setuptools3
14
15BBCLASSEXTEND = "native"
16
17DEPENDS = "python3-pkgconfig-native \
18 python3-cython-native \
19 python3-numpy-native \
20 python3-six-native \
21 hdf5-native \
22 python3 \
23 hdf5 \
24 "
25
26RDEPENDS:${PN} = "python3-numpy \
27 python3-six \
28 python3-json \
29 "
30
31export HDF5_VERSION="1.8.21"