blob: a540e3651579c7653730ea7de3b15f8b511b7ecc [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "JSON Web Token implementation in Python"
2DESCRIPTION = "A Python implementation of JSON Web Token draft 32.\
3 Original implementation was written by https://github.com/progrium"
4HOMEPAGE = "http://github.com/jpadilla/pyjwt"
5LICENSE = "MIT"
Andrew Geissler78b72792022-06-14 06:47:25 -05006LIC_FILES_CHKSUM = "file://LICENSE;md5=e4b56d2c9973d8cf54655555be06e551"
Andrew Geisslereff27472021-10-29 15:35:00 -05007
Andrew Geissler78b72792022-06-14 06:47:25 -05008SRC_URI[sha256sum] = "d42908208c699b3b973cbeb01a969ba6a96c821eefb1c5bfe4c390c01d67abba"
Andrew Geisslereff27472021-10-29 15:35:00 -05009
10PYPI_PACKAGE = "PyJWT"
11inherit pypi setuptools3
12
13RDEPENDS:${PN} = "${PYTHON_PN}-cryptography"
14
15BBCLASSEXTEND = "native nativesdk"