blob: a19ae304d5faabed2ad842e44bdf44177b5a8cb6 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "https://wireless.wiki.kernel.org/en/users/documentation/iw"
6SECTION = "base"
7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
15"
16
Andrew Geissler78b72792022-06-14 06:47:25 -050017SRC_URI[sha256sum] = "2a44676d28a87bbc232903d5d573e7618e4fae0cea3a1aff067a26fa66652b75"
Andrew Geissler595f6302022-01-24 19:11:47 +000018
19inherit pkgconfig
20
21EXTRA_OEMAKE = "\
22 -f '${S}/Makefile' \
23 \
24 'PREFIX=${prefix}' \
25 'SBINDIR=${sbindir}' \
26 'MANDIR=${mandir}' \
27"
28
29do_install() {
30 oe_runmake 'DESTDIR=${D}' install
31}