blob: 39ff19c2b8a2e328623424aa18cfc3b6a7626641 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Simple Python module for working with HTML/CSS color definitions."
2HOMEPAGE = "https://pypi.org/project/webcolors/"
3LICENSE = "BSD-3-Clause"
Andrew Geissler78b72792022-06-14 06:47:25 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=bcf737478d2fa8af5bc954231df056c6"
Andrew Geissler595f6302022-01-24 19:11:47 +00005
Andrew Geissler78b72792022-06-14 06:47:25 -05006SRC_URI[sha256sum] = "16d043d3a08fd6a1b1b7e3e9e62640d09790dce80d2bdd4792a175b35fe794a9"
Andrew Geissler595f6302022-01-24 19:11:47 +00007
8inherit pypi setuptools3 ptest
9
10RDEPENDS:${PN}:class-target = "\
11 ${PYTHON_PN}-stringold \
12"
13
14SRC_URI += " \
15 file://run-ptest \
16"
17
18RDEPENDS:${PN}-ptest += " \
19 ${PYTHON_PN}-pytest \
20"
21
22do_install_ptest() {
23 install -d ${D}${PTEST_PATH}/tests
24 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
25}
26
27BBCLASSEXTEND = "native nativesdk"