blob: 9e6d17c78094bc925b6c3af7a569b0232bcc9712 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.xz"
Andrew Geissler78b72792022-06-14 06:47:25 -050016SRC_URI[sha256sum] = "1f1bb1292a161d520a3485d378609277d108cd07cde0327c16811ff54c3e1595"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017
18SECTION = "x11/libs"
19DEPENDS = "util-macros libxslt-native"
20
21EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
22
23FILES:${PN} += "${datadir}/X11/xkb"
24
25inherit meson pkgconfig gettext python3native
26
27do_install:append () {
28 install -d ${D}${datadir}/X11/xkb/compiled
29 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
30}