blob: ebb32074dcc69267b2661d3a37b846e1aa69b855 [file] [log] [blame]
Lancelot Kao96a7ee32021-02-22 18:50:48 -06001SUMMARY = "Phosphor OpenBMC Kudo System Power Control Service"
2DESCRIPTION = "Phosphor OpenBMC Kudo System Power Control Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
12RDEPENDS_${PN} += "libsystemd"
13RDEPENDS_${PN} += "bash"
14
15SRC_URI += " \
16 file://init_once.sh \
17 file://host-powerctrl.service \
18 "
19
20SYSTEMD_PACKAGES = "${PN}"
21SYSTEMD_SERVICE_${PN} = " \
22 host-powerctrl.service \
23 "
24
25do_install () {
26 install -d ${D}${bindir}
27 install -m 0755 ${WORKDIR}/init_once.sh ${D}${bindir}/
28
29 install -d ${D}${systemd_unitdir}/system/
30 install -m 0644 ${WORKDIR}/host-powerctrl.service ${D}${systemd_unitdir}/system
31}